<p><br>
Il giorno 21/mar/2014 02:28, &quot;Sreedhar Manchu&quot; &lt;<a href="mailto:sreedhar@nyu.edu">sreedhar@nyu.edu</a>&gt; ha scritto:<br>
&gt;<br>
&gt; Hi Thomas,<br>
&gt;<br>
&gt; Thank you. I got it working by creating a soft link to torque library from /opt/torque to a place where perl-PBS was looking for it (/usr/lib64). Before I did that I deleted the torque that came with perl-PBS. It looks like I don&#39;t need to change the code because I got this version of pbstop from Gareth and I think he must have fixed it to accommodate some of the things you mentioned. <br>

&gt;<br>
&gt; # rpm -qa | grep torque<br>
&gt;<br>
&gt; torque-2.5.7-9.el6.x86_64<br>
&gt;<br>
&gt; torque-libs-2.5.7-9.el6.x86_64<br>
&gt;<br>
&gt; # rpm -e torque-2.5.7-9.el6.x86_64<br>
&gt;<br>
&gt; error: Failed dependencies:<br>
&gt;<br>
&gt; torque = 2.5.7-9.el6 is needed by (installed) torque-libs-2.5.7-9.el6.x86_64<br>
&gt;<br>
&gt; # rpm -e torque-2.5.7-9.el6.x86_64 torque-libs-2.5.7-9.el6.x86_64<br>
&gt;<br>
&gt; error: Failed dependencies:<br>
&gt;<br>
&gt; libtorque.so.2()(64bit) is needed by (installed) perl-PBS-0.33-10.el6.x86_64<br>
&gt;<br>
&gt; # rpm -e torque-2.5.7-9.el6.x86_64 torque-libs-2.5.7-9.el6.x86_64 --nodeps<br>
&gt;<br>
&gt; # ln -s /opt/torque/lib/libtorque.so.2.0.0 /usr/lib64/libtorque.so.2<br>
&gt;<br>
&gt; # ldconfig<br>
&gt;<br>
&gt;<br>
&gt; Thank you again. I appreciate it.<br>
&gt;<br>
&gt;<br>
&gt; Best,<br>
&gt;<br>
&gt; Sreedhar.<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; On Thu, Mar 20, 2014 at 3:11 AM, Thomas Dargel &lt;<a href="mailto:td@chemie.hu-berlin.de">td@chemie.hu-berlin.de</a>&gt; wrote:<br>
&gt;&gt;<br>
&gt;&gt; Hi,<br>
&gt;&gt;<br>
&gt;&gt;   I ran into trouble with pbstop when jumping from torque v2.4.4 to v4.6.2.1,<br>
&gt;&gt; too.<br>
&gt;&gt;<br>
&gt;&gt; In my case the harm came out of the subroutine &quot;sub get_info_cmdline {}&quot;.<br>
&gt;&gt; Herein I changed a search pattern for the analysis of &quot;/\s+jobs = (.*)/&quot;,<br>
&gt;&gt; because the output of &quot;qmgr -c &#39;l n @server&#39;&quot; differs slightly from v2.4.4 to<br>
&gt;&gt; v4.6.2.1 in the &quot;jobs = &quot;-section.<br>
&gt;&gt;<br>
&gt;&gt;          elsif (/\s+jobs = (.*)/) {<br>
&gt;&gt;              $eatingjobs=1;<br>
&gt;&gt;              $eatingstatus=0;<br>
&gt;&gt;              $jobs = $1;<br>
&gt;&gt;              $State_count-&gt;{&quot;_anodes&quot;}++;<br>
&gt;&gt; #  OLD       foreach my $job ( split ( /, /, $jobs ) ) {<br>
&gt;&gt;              foreach my $job ( split ( /,/, $jobs ) ) {<br>
&gt;&gt;                  if ( $job =~ m{(\d+)/(\d+)} ) {<br>
&gt;&gt;                      $Nodes-&gt;{$server}{$node}{job}{$1} = $2;<br>
&gt;&gt;                      $State_count-&gt;{&quot;_aprocs&quot;}++;<br>
&gt;&gt;                  }<br>
&gt;&gt;              }<br>
&gt;&gt;<br>
&gt;&gt; And some line later:<br>
&gt;&gt;<br>
&gt;&gt;          elsif ($eatingjobs) {<br>
&gt;&gt;             if ($_ =~ /\w/) {<br>
&gt;&gt;                /^\s+(.*)$/;<br>
&gt;&gt;                $jobs = $1;<br>
&gt;&gt; #  OLD         foreach my $job ( split ( /, /, $jobs ) ) {<br>
&gt;&gt;                foreach my $job ( split ( /,/, $jobs ) ) {<br>
&gt;&gt;                  if ( $job =~ m{(\d+)/(\d+)} ) {<br>
&gt;&gt;                      $Nodes-&gt;{$server}{$node}{job}{$1} = $2;<br>
&gt;&gt;                      $State_count-&gt;{&quot;_aprocs&quot;}++;<br>
&gt;&gt;                  }<br>
&gt;&gt;                }<br>
&gt;&gt;             }<br>
&gt;&gt;<br>
&gt;&gt;<br>
&gt;&gt; Good luck,<br>
&gt;&gt; regards,<br>
&gt;&gt;<br>
&gt;&gt;   Thomas.<br>
&gt;&gt;<br>
&gt;&gt; On 20.03.2014 05:53, Sreedhar Manchu wrote:<br>
&gt;&gt; &gt; Hi,<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; We use Torque 2.5.12 on our current systems (rhea 5.X). PBSTOP works great with<br>
&gt;&gt; &gt; this version.<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; Now I have installed Torque 4.2.7 on a new cluster with CentOS 6.3. But I&#39;m<br>
&gt;&gt; &gt; having tough time in making pbstop to work well.<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; Does anyone know how to get it working with 4.2.7? Getting it with yum is not an<br>
&gt;&gt; &gt; option as it installs a 2.5.X version of Torque.<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; Thanks in advance,<br>
&gt;&gt; &gt; Sreedhar.<br>
&gt;&gt; &gt; New York University.<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; _______________________________________________<br>
&gt;&gt; &gt; torqueusers mailing list<br>
&gt;&gt; &gt; <a href="mailto:torqueusers@supercluster.org">torqueusers@supercluster.org</a><br>
&gt;&gt; &gt; <a href="http://www.supercluster.org/mailman/listinfo/torqueusers">http://www.supercluster.org/mailman/listinfo/torqueusers</a><br>
&gt;&gt; &gt;<br>
&gt;&gt;<br>
&gt;&gt; _______________________________________________<br>
&gt;&gt; torqueusers mailing list<br>
&gt;&gt; <a href="mailto:torqueusers@supercluster.org">torqueusers@supercluster.org</a><br>
&gt;&gt; <a href="http://www.supercluster.org/mailman/listinfo/torqueusers">http://www.supercluster.org/mailman/listinfo/torqueusers</a><br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; _______________________________________________<br>
&gt; torqueusers mailing list<br>
&gt; <a href="mailto:torqueusers@supercluster.org">torqueusers@supercluster.org</a><br>
&gt; <a href="http://www.supercluster.org/mailman/listinfo/torqueusers">http://www.supercluster.org/mailman/listinfo/torqueusers</a><br>
&gt;<br>
</p>