<html><head></head><body>Hi Kamran,<br>
<br>
as far as I can see the verify script expects u using oracle Java. I would try to install oracle Java and retry installation of moab.<br>
<br>
Greetings,<br>
Marcel Gaetje<br><br><div class="gmail_quote">On 18. Februar 2014 19:10:51 MEZ, Kamran Khan &lt;kamran@pssclabs.com&gt; wrote:<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<pre class="k9mail">Hi All, <br /><br />I am installing the Moab Basic Suite on RHEL 6.5 and am running into some dependency problems. <br /><br /><hr /><br />[root@clusterhn ~]# yum install moab-hpc-basic-suite-libtorque.x86_64<br />Loaded plugins: product-id, refresh-packagekit, security, subscription-manager<br />This system is receiving updates from Red Hat Subscription Management.<br />rhel-6-server-cf-tools-1-rpms                                                               | 2.8 kB     00:00<br />rhel-6-server-rhev-agent-rpms                                                               | 3.1 kB     00:00<br />rhel-6-server-rpms                                                                          | 3.7 kB     00:00<br />Setting up Install Process<br />Resolving Dependencies<br />--&gt; Running transaction check<br />---&gt; Package moab-hpc-basic-suite-libtorque.x86_64 0:7.2.6-2013.11.07_14.53.44 will be installed<br />--&gt; Processing Dependency:
moab-verify-oracle-java = 1.6.0 for package: moab-hpc-basic-suite-libtorque-7.2.6-2013.11.07_14.53.44.x86_64<br />--&gt; Processing Dependency: moab-tomcat-config &gt;= 7.2 for package: moab-hpc-basic-suite-libtorque-7.2.6-2013.11.07_14.53.44.x86_64<br />--&gt; Processing Dependency: moab-hpc-workload-manager-libtorque &gt;= 7.2 for package: moab-hpc-basic-suite-libtorque-7.2.6-2013.11.07_14.53.44.x86_64<br />--&gt; Processing Dependency: moab-hpc-web-services &gt;= 7.2 for package: moab-hpc-basic-suite-libtorque-7.2.6-2013.11.07_14.53.44.x86_64<br />--&gt; Processing Dependency: moab-hpc-viewpoint &gt;= 7.2 for package: moab-hpc-basic-suite-libtorque-7.2.6-2013.11.07_14.53.44.x86_64<br />--&gt; Processing Dependency: tomcat6 for package: moab-hpc-basic-suite-libtorque-7.2.6-2013.11.07_14.53.44.x86_64<br />--&gt; Processing Dependency: mongo20-10gen-server for package: moab-hpc-basic-suite-libtorque-7.2.6-2013.11.07_14.53.44.x86_64<br />--&gt; Processing Dependency: mongo20-10gen
for package: moab-hpc-basic-suite-libtorque-7.2.6-2013.11.07_14.53.44.x86_64<br />--&gt; Processing Dependency: moab-torque-server for package: moab-hpc-basic-suite-libtorque-7.2.6-2013.11.07_14.53.44.x86_64<br />--&gt; Processing Dependency: moab-torque-mom for package: moab-hpc-basic-suite-libtorque-7.2.6-2013.11.07_14.53.44.x86_64<br />--&gt; Processing Dependency: moab-torque-client for package: moab-hpc-basic-suite-libtorque-7.2.6-2013.11.07_14.53.44.x86_64<br />--&gt; Running transaction check<br />---&gt; Package moab-hpc-viewpoint.x86_64 0:7.2.6-2013.11.06_13.41.17 will be installed<br />--&gt; Processing Dependency: mysql-connector-java for package: moab-hpc-viewpoint-7.2.6-2013.11.06_13.41.17.x86_64<br />---&gt; Package moab-hpc-web-services.x86_64 0:7.2.6-2013.10.30_14.45.54 will be installed<br />---&gt; Package moab-hpc-workload-manager-libtorque.x86_64 0:7.2.6-2013.11.07_14.09.40 will be installed<br />--&gt; Processing Dependency:
moab-hpc-workload-manager-libtorque-common = 7.2.6 for package: moab-hpc-workload-manager-libtorque-7.2.6-2013.11.07_14.09.40.x86_64<br />--&gt; Processing Dependency: perl(XML::Simple) for package: moab-hpc-workload-manager-libtorque-7.2.6-2013.11.07_14.09.40.x86_64<br />--&gt; Processing Dependency: perl(XML::LibXML) for package: moab-hpc-workload-manager-libtorque-7.2.6-2013.11.07_14.09.40.x86_64<br />--&gt; Processing Dependency: perl(Parse::RecDescent) for package: moab-hpc-workload-manager-libtorque-7.2.6-2013.11.07_14.09.40.x86_64<br />--&gt; Processing Dependency: perl(Log::Log4perl) for package: moab-hpc-workload-manager-libtorque-7.2.6-2013.11.07_14.09.40.x86_64<br />--&gt; Processing Dependency: perl(JSON) for package: moab-hpc-workload-manager-libtorque-7.2.6-2013.11.07_14.09.40.x86_64<br />--&gt; Processing Dependency: <a href="http://libtorque.so">libtorque.so</a>.2()(64bit) for package: moab-hpc-workload-manager-libtorque-7.2.6-2013.11.07_14.09.40.x86_64<br />---&gt;
Package moab-tomcat-config.x86_64 0:7.2.4-2013.07.25_11.47.42 will be installed<br />---&gt; Package moab-torque-client.x86_64 0:<a href="http://4.2.6.1">4.2.6.1</a>-2013.12.03_13.15.19 will be installed<br />---&gt; Package moab-torque-mom.x86_64 0:<a href="http://4.2.6.1">4.2.6.1</a>-2013.12.03_13.15.19 will be installed<br />---&gt; Package moab-torque-server.x86_64 0:<a href="http://4.2.6.1">4.2.6.1</a>-2013.12.03_13.15.19 will be installed<br />---&gt; Package moab-verify-oracle-java.x86_64 0:1.6.0-2013.08.27_13.03.44 will be installed<br />--&gt; Processing Dependency: jre &gt;= 1.6.0_32-fcs for package: moab-verify-oracle-java-1.6.0-2013.08.27_13.03.44.x86_64<br />---&gt; Package mongo20-10gen.x86_64 0:2.0.8-mongodb_1 will be installed<br />---&gt; Package mongo20-10gen-server.x86_64 0:2.0.8-mongodb_1 will be installed<br />---&gt; Package tomcat6.noarch 0:6.0.24-62.el6 will be installed<br />--&gt; Processing Dependency: tomcat6-lib = 6.0.24-62.el6 for package:
tomcat6-6.0.24-62.el6.noarch<br />--&gt; Processing Dependency: jakarta-commons-pool for package: tomcat6-6.0.24-62.el6.noarch<br />--&gt; Processing Dependency: jakarta-commons-dbcp for package: tomcat6-6.0.24-62.el6.noarch<br />--&gt; Processing Dependency: jakarta-commons-daemon for package: tomcat6-6.0.24-62.el6.noarch<br />--&gt; Processing Dependency: jakarta-commons-collections for package: tomcat6-6.0.24-62.el6.noarch<br />--&gt; Running transaction check<br />---&gt; Package jakarta-commons-collections.noarch 0:3.2.1-3.4.el6 will be installed<br />---&gt; Package jakarta-commons-daemon.x86_64 1:1.0.1-8.9.el6 will be installed<br />---&gt; Package jakarta-commons-dbcp.noarch 0:1.2.1-13.8.el6 will be installed<br />---&gt; Package jakarta-commons-pool.x86_64 0:1.3-12.7.el6 will be installed<br />---&gt; Package java-1.7.0-openjdk.x86_64 1:<a href="http://1.7.0.51">1.7.0.51</a>-<a href="http://2.4.4.1">2.4.4.1</a>.el6_5 will be installed<br />---&gt; Package
moab-hpc-workload-manager-libtorque-common.x86_64 0:7.2.6-2013.11.07_14.09.40 will be installed<br />--&gt; Processing Dependency: perl(Expect) for package: moab-hpc-workload-manager-libtorque-common-7.2.6-2013.11.07_14.09.40.x86_64<br />---&gt; Package moab-perl-JSON.noarch 0:2.53-2013.07.25_11.48.41 will be installed<br />--&gt; Processing Dependency: moab-perl-data for package: moab-perl-JSON-2.53-2013.07.25_11.48.41.noarch<br />---&gt; Package moab-perl-XML-Simple.noarch 0:2.20-2013.07.25_11.48.41 will be installed<br />---&gt; Package moab-torque-common.x86_64 0:<a href="http://4.2.6.1">4.2.6.1</a>-2013.12.03_13.15.19 will be installed<br />---&gt; Package mysql-connector-java.noarch 1:5.1.17-6.el6 will be installed<br />---&gt; Package perl-Log-Log4perl.noarch 0:1.30-1.el6 will be installed<br />--&gt; Processing Dependency: perl(Log::Dispatch::FileRotate) &gt;= 1.10 for package: perl-Log-Log4perl-1.30-1.el6.noarch<br />--&gt; Processing Dependency: perl(XML::DOM) for package:
perl-Log-Log4perl-1.30-1.el6.noarch<br />--&gt; Processing Dependency: perl(RRDs) for package: perl-Log-Log4perl-1.30-1.el6.noarch<br />--&gt; Processing Dependency: perl(Log::Dispatch::Syslog) for package: perl-Log-Log4perl-1.30-1.el6.noarch<br />--&gt; Processing Dependency: perl(Log::Dispatch::Screen) for package: perl-Log-Log4perl-1.30-1.el6.noarch<br />--&gt; Processing Dependency: perl(Log::Dispatch::File) for package: perl-Log-Log4perl-1.30-1.el6.noarch<br />---&gt; Package perl-Parse-RecDescent.noarch 0:1.965-1.el6 will be installed<br />---&gt; Package perl-XML-LibXML.x86_64 1:1.70-5.el6 will be installed<br />--&gt; Processing Dependency: perl(XML::SAX::Exception) for package: 1:perl-XML-LibXML-1.70-5.el6.x86_64<br />--&gt; Processing Dependency: perl(XML::SAX::DocumentLocator) for package: 1:perl-XML-LibXML-1.70-5.el6.x86_64<br />--&gt; Processing Dependency: perl(XML::SAX::Base) for package: 1:perl-XML-LibXML-1.70-5.el6.x86_64<br />--&gt; Processing Dependency:
perl(XML::NamespaceSupport) for package: 1:perl-XML-LibXML-1.70-5.el6.x86_64<br />---&gt; Package tomcat6-lib.noarch 0:6.0.24-62.el6 will be installed<br />--&gt; Processing Dependency: tomcat6-servlet-2.5-api = 6.0.24-62.el6 for package: tomcat6-lib-6.0.24-62.el6.noarch<br />--&gt; Processing Dependency: tomcat6-jsp-2.1-api = 6.0.24-62.el6 for package: tomcat6-lib-6.0.24-62.el6.noarch<br />--&gt; Processing Dependency: tomcat6-el-2.1-api = 6.0.24-62.el6 for package: tomcat6-lib-6.0.24-62.el6.noarch<br />--&gt; Running transaction check<br />---&gt; Package moab-perl-RRDs.x86_64 0:7.2.4-2013.07.25_13.23.32 will be installed<br />---&gt; Package moab-perl-data.x86_64 0:7.2.4-2013.07.25_13.23.02 will be installed<br />---&gt; Package perl-Expect.noarch 0:1.21-3.el6 will be installed<br />--&gt; Processing Dependency: perl(IO::Pty) &gt;= 1.03 for package: perl-Expect-1.21-3.el6.noarch<br />--&gt; Processing Dependency: perl(IO::Tty) for package: perl-Expect-1.21-3.el6.noarch<br
/>---&gt; Package perl-Log-Dispatch.noarch 0:2.27-1.el6 will be installed<br />--&gt; Processing Dependency: perl(Params::Validate) for package: perl-Log-Dispatch-2.27-1.el6.noarch<br />--&gt; Processing Dependency: perl(Mail::Sendmail) for package: perl-Log-Dispatch-2.27-1.el6.noarch<br />--&gt; Processing Dependency: perl(Mail::Sender) for package: perl-Log-Dispatch-2.27-1.el6.noarch<br />--&gt; Processing Dependency: perl(Mail::Send) for package: perl-Log-Dispatch-2.27-1.el6.noarch<br />--&gt; Processing Dependency: perl(MIME::Lite) for package: perl-Log-Dispatch-2.27-1.el6.noarch<br />---&gt; Package perl-Log-Dispatch-FileRotate.noarch 0:1.19-4.el6 will be installed<br />--&gt; Processing Dependency: perl(Date::Manip) for package: perl-Log-Dispatch-FileRotate-1.19-4.el6.noarch<br />---&gt; Package perl-XML-DOM.noarch 0:1.44-7.el6 will be installed<br />--&gt; Processing Dependency: perl(XML::RegExp) for package: perl-XML-DOM-1.44-7.el6.noarch<br />---&gt; Package
perl-XML-NamespaceSupport.noarch 0:1.10-3.el6 will be installed<br />---&gt; Package perl-XML-SAX.noarch 0:0.96-7.el6 will be installed<br />---&gt; Package tomcat6-el-2.1-api.noarch 0:6.0.24-62.el6 will be installed<br />---&gt; Package tomcat6-jsp-2.1-api.noarch 0:6.0.24-62.el6 will be installed<br />---&gt; Package tomcat6-servlet-2.5-api.noarch 0:6.0.24-62.el6 will be installed<br />--&gt; Running transaction check<br />---&gt; Package perl-Date-Manip.noarch 0:6.24-1.el6 will be installed<br />--&gt; Processing Dependency: perl(YAML::Syck) for package: perl-Date-Manip-6.24-1.el6.noarch<br />---&gt; Package perl-IO-Tty.x86_64 0:1.08-3.el6 will be installed<br />---&gt; Package perl-MIME-Lite.noarch 0:3.027-2.el6 will be installed<br />--&gt; Processing Dependency: perl(MIME::Types) &gt;= 1.28 for package: perl-MIME-Lite-3.027-2.el6.noarch<br />--&gt; Processing Dependency: perl(Email::Date::Format) for package: perl-MIME-Lite-3.027-2.el6.noarch<br />---&gt; Package
perl-Mail-Sender.noarch 0:0.8.16-3.el6 will be installed<br />---&gt; Package perl-Mail-Sendmail.noarch 0:0.79-12.el6 will be installed<br />---&gt; Package perl-MailTools.noarch 0:2.04-4.el6 will be installed<br />---&gt; Package perl-Params-Validate.x86_64 0:0.92-3.el6 will be installed<br />---&gt; Package perl-XML-RegExp.noarch 0:0.03-7.el6 will be installed<br />--&gt; Running transaction check<br />---&gt; Package perl-MIME-Lite.noarch 0:3.027-2.el6 will be installed<br />--&gt; Processing Dependency: perl(Email::Date::Format) for package: perl-MIME-Lite-3.027-2.el6.noarch<br />---&gt; Package perl-MIME-Types.noarch 0:1.28-2.el6 will be installed<br />---&gt; Package perl-YAML-Syck.x86_64 0:1.07-4.el6 will be installed<br />--&gt; Processing Conflict: moab-verify-oracle-java-1.6.0-2013.08.27_13.03.44.x86_64 conflicts jre &gt;= 1.7<br />--&gt; Finished Dependency Resolution<br />Error: Package: perl-MIME-Lite-3.027-2.el6.noarch (epel)<br />           Requires:
perl(Email::Date::Format)<br />Error: moab-verify-oracle-java conflicts with 1:java-1.7.0-openjdk-<a href="http://1.7.0.51">1.7.0.51</a>-<a href="http://2.4.4.1">2.4.4.1</a>.el6_5.x86_64<br /> You could try using --skip-broken to work around the problem<br /> You could try running: rpm -Va --nofiles --nodigest<br /><hr /><br /><br /><br />I try the two options at the bottom (--skip-broken) (rpm -Va --nofiles --nodigest) which don't resolve the issue.  When I do --skip-broken, it does skip all broken, but it also does not install all the good stuff either.<br /><br />Anybody have any suggestions?<br /><br />Please let me know if you need further information to determine the solution.<br /><br />Thanks.</pre></blockquote></div><br>
-- <br>
Diese Nachricht wurde von meinem Android-Mobiltelefon mit K-9 Mail gesendet.</body></html>