<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
<style>
<!--
@font-face
        {font-family:Helvetica}
@font-face
        {font-family:Helvetica}
@font-face
        {font-family:Calibri}
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif"}
a:link, span.MsoHyperlink
        {color:blue;
        text-decoration:underline}
a:visited, span.MsoHyperlinkFollowed
        {color:purple;
        text-decoration:underline}
span.EmailStyle17
        {font-family:"Calibri","sans-serif";
        color:windowtext}
.MsoChpDefault
        {font-family:"Calibri","sans-serif"}
@page WordSection1
        {margin:1.0in 1.0in 1.0in 1.0in}
div.WordSection1
        {}
-->
</style>
</head>
<body lang="EN-US" link="blue" vlink="purple">
<div class="WordSection1">
<p class="MsoNormal">This is a follow up to a message I submitted to the list a few months back.&nbsp; Today I submitted a test run on our dev cluster to make sure changes made to the script would work.&nbsp; I encountered an old problem&#8230;&nbsp; everything went into and stayed
 the the &#8220;Q&#8221; state.</p>
<p class="MsoNormal">&nbsp;</p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;">[root@srvDevHead01 ~]# qstat</span></p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;">Job id&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Name&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; User&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Time Use S Queue</span></p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;">------------------------- ---------------- --------------- -------- - -----</span></p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;">3827.srvdevhead01&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ...66130004.2100 eob_merge&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 0 Q batch&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
</span></p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;">3828.srvdevhead01&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ...66130004.2101 eob_merge&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 0 Q batch&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
</span></p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;">3829.srvdevhead01&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ...66130004.2102 eob_merge&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 0 Q batch&nbsp;
</span></p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span></p>
<p class="MsoNormal">When I last brought this up, Brian Andrus suggested that I try&#8230;</p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;">&nbsp;</span></p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;">[root@srvDevHead01 ~]# showq</span></p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;">ERROR:&nbsp;&nbsp;&nbsp; lost connection to server</span></p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;">ERROR:&nbsp;&nbsp;&nbsp; cannot request service (status)</span></p>
<p class="MsoNormal">&nbsp;</p>
<p class="MsoNormal">This led me to try&#8230;</p>
<p class="MsoNormal">&nbsp;</p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;"># service maui stop</span></p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;">Shutting down MAUI Scheduler: ERROR:&nbsp;&nbsp;&nbsp; lost connection to server</span></p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;">ERROR:&nbsp;&nbsp;&nbsp; cannot request service (status)</span></p>
<p class="MsoNormal"><span style="font-family:&quot;Courier New&quot;">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; [FAILED]</span></p>
<p class="MsoNormal">&nbsp;</p>
<p class="MsoNormal">After some further playing around, I eventually rebooted the headbox and showq came back with the expected result.&nbsp; And following submissions worked correctly.&nbsp; We&#8217;ve seen this both in our dev cluster and in our production cluster.&nbsp; I don&#8217;t
 mind rebooting part or all of the dev cluster.&nbsp; But having the production cluster hang isn&#8217;t a good thing.&nbsp;
</p>
<p class="MsoNormal">&nbsp;</p>
<p class="MsoNormal">I will offer that this &#8211;seems&#8211; to happen only after the cluster has been sitting without doing any work for a while&#8230; a week&#43;.</p>
<p class="MsoNormal">&nbsp;</p>
<p class="MsoNormal">Anyone have any ideas of things I should look into?</p>
<p class="MsoNormal">&nbsp;</p>
<p class="MsoNormal">Thanks!</p>
<p class="MsoNormal">jack</p>
<p class="MsoNormal">&nbsp;</p>
<p class="MsoNormal">&nbsp;</p>
<p class="MsoNormal">&nbsp;</p>
<p class="MsoNormal"><b><span style="font-size:10.5pt; font-family:&quot;Helvetica&quot;,&quot;sans-serif&quot;; color:black">Jack Wilkinson,</span></b><span style="font-size:10.5pt; font-family:&quot;Helvetica&quot;,&quot;sans-serif&quot;; color:black">&nbsp;Programmer</span></p>
<p class="MsoNormal"><span style="font-size:9.0pt; font-family:&quot;Helvetica&quot;,&quot;sans-serif&quot;; color:black">Services | VPay</span><span style="font-size:8.0pt; font-family:&quot;Helvetica&quot;,&quot;sans-serif&quot;; color:black">&reg;</span><span style="font-size:12.0pt; font-family:&quot;Times New Roman&quot;,&quot;serif&quot;; color:black"></span></p>
<p class="MsoNormal"><span style="font-size:9.0pt; font-family:&quot;Helvetica&quot;,&quot;sans-serif&quot;; color:#FF230E">P: 972.367-6622</span><span style="font-size:9.0pt; font-family:&quot;Helvetica&quot;,&quot;sans-serif&quot;; color:black"></span></p>
<p class="MsoNormal"><span style="font-size:9.0pt; font-family:&quot;Helvetica&quot;,&quot;sans-serif&quot;; color:#FF230E"><a href="mailto:jwilkinson@stoneeagle.com"><span style="color:blue">jwilkinson@stoneeagle.com</span></a></span></p>
<p class="MsoNormal"><span style="font-size:9.0pt; font-family:&quot;Helvetica&quot;,&quot;sans-serif&quot;; color:black"><a href="http://www.stoneeagle.com/"><span style="color:blue">www.stoneeagle.com</span></a></span></p>
<p class="MsoNormal"><span style="font-size:9.0pt; font-family:&quot;Helvetica&quot;,&quot;sans-serif&quot;; color:black"><a href="http://www.vpayusa.com/"><span style="color:blue">www.vpayusa.com</span></a></span><span style="font-size:12.0pt; font-family:&quot;Times New Roman&quot;,&quot;serif&quot;; color:black"></span></p>
<p class="MsoNormal"><span style="font-size:9.0pt; font-family:&quot;Helvetica&quot;,&quot;sans-serif&quot;; color:#797979">&nbsp;</span></p>
<p class="MsoNormal"><span style="font-size:9.0pt; font-family:&quot;Helvetica&quot;,&quot;sans-serif&quot;; color:#797979">111 W. Spring Valley Rd., #100</span></p>
<p class="MsoNormal"><span style="font-size:9.0pt; font-family:&quot;Helvetica&quot;,&quot;sans-serif&quot;; color:#797979">Richardson, TX 75081</span></p>
<p class="MsoNormal">&nbsp;</p>
</div>
CONFIDENTIALITY NOTICE: This email, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information. Any unauthorized review, use, disclosure, or distribution is prohibited. If you received
 this email and are not the intended recipient, please inform the sender by email reply and destroy all copies of the original message.
</body>
</html>