<div dir="ltr">Ok, i&#39;ve worked it out.<div style>Make sure that every machine in the cluster (head node + computing nodes) have the same username and uid (user id), That is, when you submit the job from user (X) on the head node then a user (X) must exist on every other machine in the cluser.</div>
<div style><br></div><div style>Thanks,</div><div style>shazly</div><div style><br></div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Mon, Jun 17, 2013 at 6:39 PM, shazly <span dir="ltr">&lt;<a href="mailto:hmelshazly@gmail.com" target="_blank">hmelshazly@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi there guys,<br>
<br>
I&#39;m having a problem with pbs i wish anyone can help me out with it.<br>
<br>
first Here are some helping info:<br>
server=hatem-Inspiron-5520<br>
client=toma-VirtualBox<br>
shazly= a user on the server<br>
job id=9.hatem-Inspiron-5520<br>
<br>
So i installed and configured pbs torque on a mini-cluster (server + one<br>
client), when i submit a job from the server, i don&#39;t get the output files,<br>
so i went to check the mom log on the client machine and i found these<br>
entries:<br>
<br>
pbs_mom;Svr;mom_server_add;server hatem-Inspiron-5520 added<br>
pbs_mom;Svr;pbs_mom;LOG_ALERT::mom_server_valid_message_source, bad connect<br>
from &quot;the server ip&quot;- unauthorized server<br>
mom_server_check_connection;sending hello to server &#39;hatem-Inspiron-5520&#39;<br>
pbs_mom;LOG_ERROR::start_exec, no password entry for user &#39;shazly&#39;<br>
pbs_mom;Req;send_sisters;sending ABORT to sisters for job &#39;9.hatem-Inspiron-<br>
5520&#39;<br>
pbs_mom;Svr;pbs_mom;LOG_ERROR::sucess(0) in fork_to_user, cannot find<br>
&#39;shazly&#39; in password file<br>
pbs_mom;Req;req_reject;Reject reply code=15025(BAD UID for job execution<br>
REJHOST=toma-virtualbox MSG=cannot find user &#39;shazly&#39; in password file),<br>
aux=0, type=CopyFiles, from PBS_Server@hatem-Inspiron-5520<br>
pbs_mom;Svr;pbs_mom;LOG_ERROR::Inappropriate ioctl for device (25) in<br>
req_cpyfile, fork_to_user failed with rc=-15025 &#39;cannot find user &#39;shazly&#39;<br>
in password file&#39;-returning failure<br>
pbs_mom;Job;removed job script<br>
<br>
Also when i run &quot;qstat -f&quot; on the server afer submitting the job i get:<br>
sched_hint=Post Job file processing error; job 9.hatem-Inspiron-5520 on host<br>
toma-VirtualBox/0 BAD UID for job execution REJHOST=toma-virtualBox<br>
MSG=cannot find user &#39;shazly&#39; in password file<br>
exit_status=-1<br>
<br>
Everything in /etc/hosts is fine and i can ssh from server to client<br>
passwordless and vice-versa and i can ping both ips. I&#39;m frustrated here so<br>
any help is appreciated.<br>
<br>
Thanks<br>
<br>
<br>
_______________________________________________<br>
torqueusers mailing list<br>
<a href="mailto:torqueusers@supercluster.org">torqueusers@supercluster.org</a><br>
<a href="http://www.supercluster.org/mailman/listinfo/torqueusers" target="_blank">http://www.supercluster.org/mailman/listinfo/torqueusers</a><br>
</blockquote></div><br></div>