<html><body><div style="color:#000; background-color:#fff; font-family:times new roman, new york, times, serif;font-size:14pt"><div><span>Hello,</span></div><div><span></span>&nbsp;</div><div><span>I did not get any replies to my post, so I am resending just in case it was missed.&nbsp; Thank all in advance.&nbsp; Sam.</span></div><div><br><blockquote style="padding-left: 5px; margin-top: 5px; margin-left: 5px; border-left-color: rgb(16, 16, 255); border-left-width: 2px; border-left-style: solid;">  <div style="font-family: times new roman, new york, times, serif; font-size: 14pt;"> <div style="font-family: times new roman, new york, times, serif; font-size: 12pt;"> <div dir="ltr"> <font size="2" face="Arial"> <div style="margin: 5px 0px; padding: 0px; border: 1px solid rgb(204, 204, 204); height: 0px; line-height: 0; font-size: 0px;" class="hr" contentEditable="false" readonly="true"></div>  <b><span style="font-weight: bold;">From:</span></b> Sam
 Oubari &lt;soubari@yahoo.com&gt;<br> <b><span style="font-weight: bold;">To:</span></b> "torqueusers@supercluster.org" &lt;torqueusers@supercluster.org&gt; <br> <b><span style="font-weight: bold;">Sent:</span></b> Thursday, January 31, 2013 11:41 PM<br> <b><span style="font-weight: bold;">Subject:</span></b> Re: Broken Scheduling Puzzle<br> </font> </div> <br>
<div id="yiv1694198627"><div><div style="color: rgb(0, 0, 0); font-family: times new roman, new york, times, serif; font-size: 14pt; background-color: rgb(255, 255, 255);"><div><span>Correction, the stuck jobs stay&nbsp;in a&nbsp;W state and some were submitted earlier in the same day. </span><span>Also, when I compare output of "<span id="yiv1694198627misspell-0" class="yiv1694198627mark">qstat</span> -f" for one&nbsp;job before and after being stuck, it shows these lines were&nbsp;added:</span></div><div><span>21a22<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp; Resource_List.<span id="yiv1694198627misspell-1" class="yiv1694198627mark">neednodes</span> = 1<br>108a110,113<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp; <span id="yiv1694198627misspell-2" class="yiv1694198627mark">euser</span> = <span id="yiv1694198627misspell-3" class="yiv1694198627mark">rpt</span>_prod<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp; <span id="yiv1694198627misspell-4" class="yiv1694198627mark">egroup</span> = <span
 id="yiv1694198627misspell-5" class="yiv1694198627mark">rpt</span><br>&gt;&nbsp;&nbsp;&nbsp;&nbsp; queue_rank = 102241<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp; queue_type = E<br></span></div><div><span>Thank you,
 Sam.</span></div><div><br><div><blockquote style="padding-left: 5px; margin-top: 5px; margin-left: 5px; border-left-color: rgb(16, 16, 255); border-left-width: 2px; border-left-style: solid;">  <div style="font-family: times new roman, new york, times, serif; font-size: 14pt;"> <div style="font-family: times new roman, new york, times, serif; font-size: 12pt;"> <div dir="ltr"> <font size="2" face="Arial"> <div style="margin: 5px 0px; padding: 0px; border: 1px solid rgb(204, 204, 204); height: 0px; line-height: 0; font-size: 0px;" class="yiv1694198627hr"></div>  <b><span style="font-weight: bold;">From:</span></b> Sam Oubari &lt;soubari@yahoo.com&gt;<br> <b><span style="font-weight: bold;">To:</span></b> "torqueusers@supercluster.org" &lt;torqueusers@supercluster.org&gt; <br> <b><span style="font-weight: bold;">Sent:</span></b> Thursday, January 31, 2013 8:24 PM<br> <b><span style="font-weight: bold;">Subject:</span></b> Broken
 Scheduling Puzzle<br> </font> </div> <br>
<div id="yiv1694198627"><div><div style="color: rgb(0, 0, 0); font-family: times new roman, new york, times, serif; font-size: 14pt; background-color: rgb(255, 255, 255);"><div><span>Hello,</span></div><div><span></span> </div><div><span>I have one but very busy PROD PBS 2.5.11 on x86-64&nbsp;server using a local <span id="yiv1694198627misspell-0" class="yiv1694198627mark"><span id="yiv1694198627misspell-7" class="yiv1694198627mark">pbs</span></span>_<span id="yiv1694198627misspell-1" class="yiv1694198627mark"><span id="yiv1694198627misspell-8" class="yiv1694198627mark">sched</span></span> and all components and clients are running on the same server.</span></div><div><span></span>&nbsp;</div><div><span>Currently, if I have jobs from the day before waiting for future exec date, and I <span id="yiv1694198627misspell-2" class="yiv1694198627mark"><span id="yiv1694198627misspell-9" class="yiv1694198627mark">qsub</span></span> a new job with a future time,
 then <span id="yiv1694198627misspell-3" class="yiv1694198627mark"><span id="yiv1694198627misspell-10" class="yiv1694198627mark">qmove</span></span> it to another queue and <span id="yiv1694198627misspell-4" class="yiv1694198627mark"><span id="yiv1694198627misspell-11" class="yiv1694198627mark">qalter</span></span> it to&nbsp;a more distant future date, then some of the waiting jobs move to Q status&nbsp;at exec time but don't run.  The moved job and all other jobs run as they should.  All the jobs on this server
 are generally executing simple scripts.&nbsp; Normally, since 2.4.x, this problem shows up rarely and randomly, but for about a week now, I can re-produce on demand but not on my TEST server.</span></div><div><span></span>&nbsp;</div><div><span>Any ideas what I should try?</span></div><div><span></span>&nbsp;</div><div><span>Sam.</span></div><div><br></div></div></div></div><br><br> </div> </div> </blockquote></div>   </div></div></div></div><br><br> </div> </div> </blockquote></div>   </div></body></html>