<br><br><div class="gmail_quote">On Tue, Feb 14, 2012 at 1:24 PM, Gustavo Correa <span dir="ltr">&lt;<a href="mailto:gus@ldeo.columbia.edu">gus@ldeo.columbia.edu</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Make sure pbs_sched [Xor alternatively maui, if you installed it] is running.<br></blockquote><div><br></div><div>Thanks for the response.</div><div><br></div><div>It appears to be running.</div><div><br></div><div>[root@wings etc]# ps -ef | grep pbs</div>
<div>root      6896  6509  0 12:25 pts/24   00:00:00 grep pbs</div><div>root     12576     1  0 Feb10 ?        00:00:00 pbs_sched</div><div>root     25810     1  0 Feb10 ?        00:00:26 pbs_server -H admin.default.domain</div>
<div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
Also, as root, on the pbs_server computer, enable scheduling:<br>
qmgr -c &#39;set server scheduling=True&#39;<br></blockquote><div><br></div><div>And it appears that server scheduling is already set for True</div><div><br></div><div>[root@wings etc]# qmgr</div><div>Max open servers: 10239</div>
<div>Qmgr: print server</div><div>#</div><div># Create queues and set their attributes.</div><div>#</div><div>#</div><div># Create and define queue batch</div><div>#</div><div>create queue batch</div><div>set queue batch queue_type = Execution</div>
<div>set queue batch Priority = 100</div><div>set queue batch max_running = 300</div><div>set queue batch enabled = True</div><div>set queue batch started = True</div><div>#</div><div># Set server attributes.</div><div>#</div>
<div>set server scheduling = True</div><div>set server acl_hosts = admin.default.domain</div><div>set server acl_hosts += <a href="http://wings.glerl.noaa.gov">wings.glerl.noaa.gov</a></div><div>set server default_queue = batch</div>
<div>set server log_events = 511</div><div>set server mail_from = adm</div><div>set server scheduler_iteration = 600</div><div>set server node_check_rate = 150</div><div>set server tcp_timeout = 6</div><div>set server mom_job_sync = True</div>
<div>set server keep_completed = 300</div><div>set server next_job_number = 8</div><div><br></div><div>By the way, what is the best way to get both the server and scheduler to start at run time? </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

<br>
I hope this helps,<br>
Gus Correa<br>
<div class="HOEnZb"><div class="h5"><br>
On Feb 14, 2012, at 10:36 AM, Grigory Shamov wrote:<br>
<br>
&gt; Do you have a scheduler installed? Like, Maui, Moab?<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; --- On Tue, 2/14/12, Christina Salls &lt;<a href="mailto:christina.salls@noaa.gov">christina.salls@noaa.gov</a>&gt; wrote:<br>
&gt;<br>
&gt; From: Christina Salls &lt;<a href="mailto:christina.salls@noaa.gov">christina.salls@noaa.gov</a>&gt;<br>
&gt; Subject: [torqueusers] Basic torque config<br>
&gt; To: &quot;Torque Users Mailing List&quot; &lt;<a href="mailto:torqueusers@supercluster.org">torqueusers@supercluster.org</a>&gt;, &quot;Brian Beagan&quot; &lt;<a href="mailto:beagan@sgi.com">beagan@sgi.com</a>&gt;, &quot;John Cardenas&quot; &lt;<a href="mailto:cardenas@sgi.com">cardenas@sgi.com</a>&gt;, &quot;Jeff Hanson&quot; &lt;<a href="mailto:jhanson@sgi.com">jhanson@sgi.com</a>&gt;, &quot;Michael Saxon&quot; &lt;<a href="mailto:saxonm@sgi.com">saxonm@sgi.com</a>&gt;, &quot;help &gt;&gt; GLERL IT Help&quot; &lt;<a href="mailto:oar.glerl.it-help@noaa.gov">oar.glerl.it-help@noaa.gov</a>&gt;, <a href="mailto:keenandr@msu.edu">keenandr@msu.edu</a><br>

&gt; Date: Tuesday, February 14, 2012, 6:36 AM<br>
&gt;<br>
&gt; Hi all,<br>
&gt;<br>
&gt;       I finally made some progress but am not all the way there yet.  I changed the hostname of the server to admin, which is the hostname assigned to the interface that the compute nodes are physically connected to.  Now my pbsnodes command shows the nodes as free!!<br>

&gt;<br>
&gt; [root@wings torque]# pbsnodes -a<br>
&gt; n001.default.domain<br>
&gt;      state = free<br>
&gt;      np = 1<br>
&gt;      ntype = cluster<br>
&gt;      status = rectime=1328910309,varattr=,jobs=,state=free,netload=700143,gres=,loadave=0.02,ncpus=24,physmem=20463136kb,availmem=27835692kb,totmem=28655128kb,idletime=1502,nusers=0,nsessions=? 0,sessions=? 0,uname=Linux n001 2.6.32-131.0.15.el6.x86_64 #1 SMP Tue May 10 15:42:40 EDT 2011 x86_64,opsys=linux<br>

&gt;      gpus = 0<br>
&gt;<br>
&gt; n002.default.domain<br>
&gt;      state = free<br>
&gt;      np = 1<br>
&gt;      ntype = cluster<br>
&gt;      status = rectime=1328910310,varattr=,jobs=,state=free,netload=712138,gres=,loadave=0.00,ncpus=24,physmem=24600084kb,availmem=31894548kb,totmem=32792076kb,idletime=1510,nusers=0,nsessions=? 0,sessions=? 0,uname=Linux n002 2.6.32-131.0.15.el6.x86_64 #1 SMP Tue May 10 15:42:40 EDT 2011 x86_64,opsys=linux<br>

&gt;      gpus = 0<br>
&gt;<br>
&gt; ....For all 20 nodes.<br>
&gt;<br>
&gt; And now when I submit a job, I get a job id back, however, the jobs stays in the queue state.<br>
&gt;<br>
&gt; -bash-4.1$ ./example_submit_script_1<br>
&gt; Fri Feb 10 15:46:35 CST 2012<br>
&gt; Fri Feb 10 15:46:45 CST 2012<br>
&gt; -bash-4.1$ ./example_submit_script_1 | qsub<br>
&gt; 6.admin.default.domain<br>
&gt; -bash-4.1$ qstat<br>
&gt; Job id                    Name             User            Time Use S Queue<br>
&gt; ------------------------- ---------------- --------------- -------- - -----<br>
&gt; 4.wings                    STDIN            salls                  0 Q batch<br>
&gt; 5.wings                    STDIN            salls                  0 Q batch<br>
&gt; 6.admin                    STDIN            salls                  0 Q batch<br>
&gt;<br>
&gt; I deleted the two jobs that were created when wings was the server in case they were getting in the way<br>
&gt;<br>
&gt; [root@wings torque]# qstat<br>
&gt; Job id                    Name             User            Time Use S Queue<br>
&gt; ------------------------- ---------------- --------------- -------- - -----<br>
&gt; 6.admin                    STDIN            salls                  0 Q batch<br>
&gt; [root@wings torque]# qstat -a<br>
&gt;<br>
&gt; admin.default.domain:<br>
&gt;                                                                          Req&#39;d  Req&#39;d   Elap<br>
&gt; Job ID               Username Queue    Jobname          SessID NDS   TSK Memory Time  S Time<br>
&gt; -------------------- -------- -------- ---------------- ------ ----- --- ------ ----- - -----<br>
&gt; 6.admin.default.     salls    batch    STDIN               --    --   --    --    --  Q   --<br>
&gt; [root@wings torque]#<br>
&gt;<br>
&gt;<br>
&gt; I don&#39;t see anything that seems significant in the logs:<br>
&gt;<br>
&gt; Lots of entries like this in the server log:<br>
&gt; 02/14/2012 08:05:10;0002;PBS_Server;Svr;PBS_Server;Torque Server Version = 2.5.9, loglevel = 0<br>
&gt; 02/14/2012 08:10:10;0002;PBS_Server;Svr;PBS_Server;Torque Server Version = 2.5.9, loglevel = 0<br>
&gt; 02/14/2012 08:15:10;0002;PBS_Server;Svr;PBS_Server;Torque Server Version = 2.5.9, loglevel = 0<br>
&gt;<br>
&gt; This is the entirety of the sched_log:<br>
&gt;<br>
&gt; 02/10/2012 07:06:52;0002; pbs_sched;Svr;Log;Log opened<br>
&gt; 02/10/2012 07:06:52;0002; pbs_sched;Svr;TokenAct;Account file /var/spool/torque/sched_priv/accounting/20120210 opened<br>
&gt; 02/10/2012 07:06:52;0002; pbs_sched;Svr;main;pbs_sched startup pid 12576<br>
&gt; 02/10/2012 07:09:14;0080; pbs_sched;Svr;main;brk point 6848512<br>
&gt; 02/10/2012 15:45:04;0002; pbs_sched;Svr;Log;Log opened<br>
&gt; 02/10/2012 15:45:04;0001; pbs_sched;Svr;pbs_sched;LOG_ERROR::Address already in use (98) in main, bind<br>
&gt; 02/10/2012 15:45:04;0002; pbs_sched;Svr;die;abnormal termination<br>
&gt; 02/10/2012 15:45:04;0002; pbs_sched;Svr;Log;Log closed<br>
&gt;<br>
&gt; mom logs on the compute nodes have the same multiple entries:<br>
&gt;<br>
&gt; 02/14/2012 08:03:00;0002;   pbs_mom;Svr;pbs_mom;Torque Mom Version = 2.5.9, loglevel = 0<br>
&gt; 02/14/2012 08:08:00;0002;   pbs_mom;Svr;pbs_mom;Torque Mom Version = 2.5.9, loglevel = 0<br>
&gt; 02/14/2012 08:13:00;0002;   pbs_mom;Svr;pbs_mom;Torque Mom Version = 2.5.9, loglevel = 0<br>
&gt; 02/14/2012 08:18:00;0002;   pbs_mom;Svr;pbs_mom;Torque Mom Version = 2.5.9, loglevel = 0<br>
&gt; 02/14/2012 08:23:00;0002;   pbs_mom;Svr;pbs_mom;Torque Mom Version = 2.5.9, loglevel = 0<br>
&gt;<br>
&gt; ps looks like this:<br>
&gt;<br>
&gt; -bash-4.1$ ps -ef | grep pbs<br>
&gt; root     12576     1  0 Feb10 ?        00:00:00 pbs_sched<br>
&gt; salls    12727 26862  0 08:19 pts/0    00:00:00 grep pbs<br>
&gt; root     25810     1  0 Feb10 ?        00:00:25 pbs_server -H admin.default.domain<br>
&gt;<br>
&gt; The server and queue settings are as follows:<br>
&gt;<br>
&gt; Qmgr: list server<br>
&gt; Server admin.default.domain<br>
&gt;       server_state = Active<br>
&gt;       scheduling = True<br>
&gt;       total_jobs = 1<br>
&gt;       state_count = Transit:0 Queued:1 Held:0 Waiting:0 Running:0 Exiting:0<br>
&gt;       acl_hosts = admin.default.domain,<a href="http://wings.glerl.noaa.gov" target="_blank">wings.glerl.noaa.gov</a><br>
&gt;       default_queue = batch<br>
&gt;       log_events = 511<br>
&gt;       mail_from = adm<br>
&gt;       scheduler_iteration = 600<br>
&gt;       node_check_rate = 150<br>
&gt;       tcp_timeout = 6<br>
&gt;       mom_job_sync = True<br>
&gt;       pbs_version = 2.5.9<br>
&gt;       keep_completed = 300<br>
&gt;       next_job_number = 7<br>
&gt;       net_counter = 1 0 0<br>
&gt;<br>
&gt; Qmgr: list queue batch<br>
&gt; Queue batch<br>
&gt;       queue_type = Execution<br>
&gt;       Priority = 100<br>
&gt;       total_jobs = 1<br>
&gt;       state_count = Transit:0 Queued:1 Held:0 Waiting:0 Running:0 Exiting:0<br>
&gt;       max_running = 300<br>
&gt;       mtime = Thu Feb  9 18:22:33 2012<br>
&gt;       enabled = True<br>
&gt;       started = True<br>
&gt;<br>
&gt; Do I need to create a routing queue?  It seems like I am missing a basic element here.<br>
&gt;<br>
&gt; Thanks in advance,<br>
&gt;<br>
&gt; Christina<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; --<br>
&gt; Christina A. Salls<br>
&gt; GLERL Computer Group<br>
&gt; <a href="mailto:help.glerl@noaa.gov">help.glerl@noaa.gov</a><br>
&gt; Help Desk x2127<br>
&gt; <a href="mailto:Christina.Salls@noaa.gov">Christina.Salls@noaa.gov</a><br>
&gt; Voice Mail <a href="tel:734-741-2446" value="+17347412446">734-741-2446</a><br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; -----Inline Attachment Follows-----<br>
&gt;<br>
&gt; _______________________________________________<br>
&gt; torqueusers mailing list<br>
&gt; <a href="mailto:torqueusers@supercluster.org">torqueusers@supercluster.org</a><br>
&gt; <a href="http://www.supercluster.org/mailman/listinfo/torqueusers" target="_blank">http://www.supercluster.org/mailman/listinfo/torqueusers</a><br>
&gt; _______________________________________________<br>
&gt; torqueusers mailing list<br>
&gt; <a href="mailto:torqueusers@supercluster.org">torqueusers@supercluster.org</a><br>
&gt; <a href="http://www.supercluster.org/mailman/listinfo/torqueusers" target="_blank">http://www.supercluster.org/mailman/listinfo/torqueusers</a><br>
<br>
_______________________________________________<br>
torqueusers mailing list<br>
<a href="mailto:torqueusers@supercluster.org">torqueusers@supercluster.org</a><br>
<a href="http://www.supercluster.org/mailman/listinfo/torqueusers" target="_blank">http://www.supercluster.org/mailman/listinfo/torqueusers</a><br>
</div></div></blockquote></div><br><br clear="all"><div><br></div>-- <br>Christina A. Salls<div>GLERL Computer Group</div><div><a href="mailto:help.glerl@noaa.gov" target="_blank">help.glerl@noaa.gov</a></div><div>Help Desk x2127</div>
<div><a href="mailto:Christina.Salls@noaa.gov" target="_blank">Christina.Salls@noaa.gov</a></div><div>Voice Mail 734-741-2446 </div><div><br></div><br>