<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body text="#000000" bgcolor="#ffffff">
    <span id="IDstID">
      <meta http-equiv="Content-Type" content="text/html;
        charset=ISO-8859-1">
      <title id="ridTitle">Wimasis SL</title>
      <style><!-- body    p  --></style>
      <link href="outlook_print.css" rel="stylesheet" type="text/css"
        media="print">
      <style type="text/css"><!--.Stil1 --></style><span id="_AthCaret"></span>
      <p align="left">Thank you a lot for your reply ken.<br>
      </p>
      <p align="left">Actually you are absolutely right, MOMs have
        nothing to do with qsub, at least regarding my problem.<br>
      </p>
      <p align="left">Nevertheless it's strange, because if I disallow
        the user of that host to submit jobs, it is not able to submit,
        but if It is authorized I get that error.<br>
      </p>
      <p align="left">I have also check the code according to the link I
        mentioned on the first post of this thread and it seems that the
        code is correct.<br>
      </p>
      <p align="left">Any ideas?<br>
      </p>
    </span>
    <blockquote
      cite="mid:mailman.7193.1312477987.3123.torqueusers@supercluster.org"
      type="cite">
      <pre wrap="">----- Original Message -----
</pre>
      <blockquote type="cite" style="color: rgb(0, 0, 0);">
        <pre wrap=""><span class="moz-txt-citetags">&gt; </span>From: "Carlos M. Camara Mora" <a moz-do-not-send="true" class="moz-txt-link-rfc2396E" href="mailto:carlos.camara@wimasis.com">&lt;carlos.camara@wimasis.com&gt;</a>
<span class="moz-txt-citetags">&gt; </span>To: <a moz-do-not-send="true" class="moz-txt-link-abbreviated" href="mailto:torqueusers@supercluster.org">torqueusers@supercluster.org</a>
<span class="moz-txt-citetags">&gt; </span>Sent: Thursday, August 4, 2011 5:31:06 AM
<span class="moz-txt-citetags">&gt; </span>Subject: [torqueusers] Error: qsub: Invalid request MSG=no job owner specified
<span class="moz-txt-citetags">&gt; </span>Wimasis SL
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>I am having issues with my torque installation. The server details
<span class="moz-txt-citetags">&gt; </span>are:
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>- torque-2.5.7
<span class="moz-txt-citetags">&gt; </span>- Configured without privports but with Munge
<span class="moz-txt-citetags">&gt; </span>- Munge 0.5.10 running in all machines
<span class="moz-txt-citetags">&gt; </span>- One Server and 2 MOMs plus the server MOM
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>When I try to submit any job with:
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>echo "sleep 30" | qsub
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>from on of the MOM machines, I get the following error:
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>Error: qsub: Invalid request MSG=no job owner specified But the weird
<span class="moz-txt-citetags">&gt; </span>thing is that it only happen in one of the MOMs and that I can swear
<span class="moz-txt-citetags">&gt; </span>it was working two days ago.
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>Does anyone have a hint about the problem? I have found a similar
<span class="moz-txt-citetags">&gt; </span>problem on this list, but I think it was solved:
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span><a moz-do-not-send="true" class="moz-txt-link-freetext" href="http://www.clusterresources.com/pipermail/torqueusers/2009-February/008733.html">http://www.clusterresources.com/pipermail/torqueusers/2009-February/008733.html</a>
<span class="moz-txt-citetags">&gt; </span>
</pre>
      </blockquote>
      <pre wrap="">Carlos,

The qsub operation only happens between the client and the pbs_server. The MOM's are not involved in the job submission. 

I know that does not answer the question but hopefully it helps you with your investigation of the problem.

Ken

</pre>
    </blockquote>
  </body>
</html>