<HTML>
<HEAD>
<TITLE>Torque HA w/Maui + BLCR [SEC=UNCLASSIFIED]</TITLE>
</HEAD>
<BODY>
<FONT FACE="Calibri, Verdana, Helvetica, Arial"><SPAN STYLE='font-size:11pt'>Hi All,<BR>
<BR>
I know I am shooting high here but has anyone got torque running in Torque HA mode (v. 2.5.3) using both Maui (3.3) and BLCR (I think this one my be my show stopper for HA). I am currently evaluating the power of HA with torque and what I wish to achieve is the ability to submit jobs from 2 nominated &#8216;head nodes&#8217; for my cluster incase someone is special enough to send a compile or even run a job that goes &#8216;wild&#8217; and crashed my head node (has happened). The machine comes back and jobs continue to run, but the nodes status goes into a bit of a mess when the box crashes, as I would expect (torque does handle it quite well).<BR>
<BR>
I am currently testing the following on a two Scientific Linux 5.5 x86_64 VMs to see how far I should go in my production environment. I would love to get this all working and help the devs of torque if this does not work.<BR>
<BR>
I have built each VM with BLCR and installed RPMs of 2.5.3 with &#8216;--enable-blcr --enable-high-availability&#8217;. I then built Maui, started both after setting server_name &#8216;server1,server2&#8217; and set the following (it seems when I started the second node all the conf was already there &#8211; so I took that as a good thing):<BR>
<BR>
qmgr -c &quot;set server acl_hosts += c-test.ansto.gov.au&quot;<BR>
qmgr -c &quot;set server acl_hosts += f-test.ansto.gov.au&quot;<BR>
qmgr -c &quot;set lock_file = &quot;/data1/var/run/pbs_server.lock&quot;<BR>
qmgr -c &quot;set lock_file_check_time = 5&quot;<BR>
<BR>
I have also mounted (and plan to mount on my test compute nodes) a common /var/spool/torque/checkpoint NFS mountpoint. I could not work out if I required a common /var/spool/torque/server_priv on each &#8216;headnode&#8217; ... Is that the case?<BR>
<BR>
P.S. <BR>
I have found a few bugs with building RPMs and installing using &#8216;--enable-blcr&#8217; - I will log a bug report<BR>
</SPAN></FONT><UL><LI><FONT FACE="Calibri, Verdana, Helvetica, Arial"><SPAN STYLE='font-size:11pt'>Can&#8217;t start torque until I manually create /var/spool/torque/checkpoint<BR>
</SPAN></FONT></UL><FONT FACE="Calibri, Verdana, Helvetica, Arial"><SPAN STYLE='font-size:11pt'><BR>
Please let me know if I have done anything dumb or that could be done better / correctly.<BR>
<BR>
Ta and Thanks for such an awesome free PBS system,<BR>
--<BR>
Cooper Ry Lees<BR>
HPC / UNIX Systems Administrator - Information Management Services (IMS)<BR>
Australian Nuclear Science and Technology Organisation<BR>
T &nbsp;+61 2 9717 3853<BR>
F &nbsp;+61 2 9717 9273<BR>
M &nbsp;+61 403 739 446<BR>
E &nbsp;<a href="cooper.lees@ansto.gov.au">cooper.lees@ansto.gov.au</a><BR>
www.ansto.gov.au &lt;<a href="http://www.ansto.gov.au">http://www.ansto.gov.au</a>&gt;<BR>
<BR>
Important: This transmission is intended only for the use of the addressee.<BR>
It is confidential and may contain privileged information or copyright material. If you are not the intended recipient, any use or further disclosure of this communication is strictly forbidden. If you have received this transmission in error, please notify me immediately by telephone and delete all copies of this transmission as well as any attachments.<BR>
</SPAN></FONT>
</BODY>
</HTML>