<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html; charset=ISO-8859-1"
 http-equiv="Content-Type">
</head>
<body text="#000000" bgcolor="#ffffff">
<br>
<pre wrap="">Hi&nbsp; Felix!

Thanks that you have time for Torque even on your vacation.<!--EndFragment-->
</pre>
<br>
14.07.2010 19:01, Felix Wolfheimer wrote:<br>
<blockquote cite="mid:1279123270.2247.13.camel@blauerpfeil" type="cite">
  <pre wrap="">Some comments already:
I faced the "Administrator" problem I mentioned before (all user
accounts are assigned to primary group "none") with this version of
Torque: 

<a class="moz-txt-link-freetext" href="http://www.clusterresources.com/downloads/torque/snapshots/torque-2.5-beta_0.20100702.tar.gz">http://www.clusterresources.com/downloads/torque/snapshots/torque-2.5-beta_0.20100702.tar.gz</a> 

which is the official beta of 2.5.0 I think. </pre>
</blockquote>
<br>
<pre wrap="">Cygwin often uses group 'None' (513) or group 'Domain Users' (10513).<meta
 name="qrichtext" content="1"><meta http-equiv="Content-Type"
 content="text/html; charset=ISO-8859-1"><style type="text/css">
p, li { white-space: pre-wrap; }
</style>
This is its some specificity<!--EndFragment-->.
But Torque works nevertheless<!--EndFragment-->.
<p style="margin: 0px; text-indent: 0px;">
You can use the 'id' Cygwin's command for more detailed information<!--EndFragment--> about users and groups.
For example:
</p>
Administrator@vxp64 ~
$ id
uid=500(Administrator) gid=513(None) groups=513(None),544(Administrators),545(Users)

user@vxp64 ~
$ id
uid=1003(user) gid=513(None) groups=513(None),545(Users)

</pre>
<blockquote cite="mid:1279123270.2247.13.camel@blauerpfeil" type="cite">
  <pre wrap="">I looked into the source
code (I love Open Source Software :-)) and the problem occurred in
src/lib/Liblog/chk_file_sec.c. There is a check which tests if the user
account running the program belongs to the group with id 544 which is
the local "Administrators" group. This gave me the idea of checking
the /etc/passwd and /etc/groups files. From what you described about the
mkgroup in Cygwin 1.7 I guess that all users of Cygwin 1.7 will face
this problem somehow. 

  </pre>
</blockquote>
<pre wrap="">For Cygwin 1.7 in Torque-2.5-beta this problem is solved already,
and so  I am surprised that you mention it<!--EndFragment-->.

Check your version.<meta name="qrichtext" content="1"><meta
 http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"><style
 type="text/css">
p, li { white-space: pre-wrap; }
</style>
Was it rewritten?<!--EndFragment-->
</pre>
<blockquote cite="mid:1279123270.2247.13.camel@blauerpfeil" type="cite">
  <pre wrap="">As mentioned in my first post I plan to use Torque for the management of
user jobs on our Windows cluster (the Linux cluster is already running
smoothly under the control of Torque) which consists of Windows Server
2003 R2 x64 and Windows Server 2008 R2 x64 systems (actually two
clusters). The XP x64 system is just a playground as it is not a
production system. If I can't get it to work there I'll try on one of
the servers.
  </pre>
</blockquote>
<pre wrap=""><meta name="qrichtext" content="1"><meta
 http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"><style
 type="text/css">
p, li { white-space: pre-wrap; }
</style>It is very interesting for our team.
<p style="margin: 0px; text-indent: 0px;">Especially Server 2003 x64 and Server 2008 x64 which haven't been tested yet.</p><p
 style="margin: 0px; text-indent: 0px;"><!--EndFragment--></p>

-- 
</pre>
<pre class="moz-signature" cols="72">
Igor  Ilyenko

Software Architect

United Institute of Information Problems NAS of Belarus
<a class="moz-txt-link-freetext" href="http://uiip.bas-net.by">http://uiip.bas-net.by</a>
</pre>
</body>
</html>