<DIV>Dear all,</DIV>
<DIV>&nbsp;</DIV>
<DIV>I have installed torque-2.3.0 on 4 machines:1 master and 3 slaves. When I start the pbs_mom of the slave machines and&nbsp;use "pbsnodes -a" to check their status, the result is correct: 3 machines are list and the status of all the 3 machines are "free".</DIV>
<DIV>&nbsp;</DIV>
<DIV>But if I submit a job script on the master to check the $PBS_NODEFILE, as following:</DIV>
<DIV><FONT face="Times New Roman">#!/bin/tcsh<BR><FONT style="FONT-SIZE: 12pt">#PBS -o /usr/local/out</FONT></FONT><BR><FONT style="FONT-SIZE: 12pt"><FONT face="Times New Roman ">#PBS -e /usr/local/err</FONT></FONT><BR><FONT style="FONT-SIZE: 12pt"><FONT face="Times New Roman ">cd $PBS_O_WORKDIR</FONT></FONT></DIV>
<DIV><FONT face="Times New Roman" size="3">cat $PBS_NODEFILE</FONT></DIV>
<DIV><FONT face="Times New Roman" size="3"></FONT>&nbsp;</DIV>
<DIV><FONT face="Times New Roman" size="3">And then I used "vim /usr/local/out" to check the output, found that there was only 1 node (the first slave node)&nbsp;displayed in the output file. Why?</FONT></DIV>
<DIV><FONT face="Times New Roman" size="3"></FONT>&nbsp;</DIV>
<DIV><FONT face="Times New Roman" size="3">Any help will be appraciated</FONT></DIV>
<DIV><FONT face="Times New Roman" size="3">Thanks!</FONT></DIV>
<DIV><FONT face="Times New Roman" size="3"></FONT>&nbsp;</DIV>
<DIV><FONT face="Times New Roman" size="3">Regards,</FONT></DIV>
<DIV><FONT face="Times New Roman" size="3">Tracy</FONT></DIV>
<DIV><BR><BR>&nbsp;</DIV><br><!-- footer --><br><span title="neteasefooter"/><hr/>
<a href="http://www.yeah.net">网易邮箱,中国第一大电子邮件服务商</a>
</span>