Joshua Bernstein <span dir="ltr"></span>wrote:<br><div class="gmail_quote"><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><div class="Ih2E3d">
<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
I am trying to set up a queue on a Mac Pro cluster running OSX Leopard 10.5.6 (the following problem existed on an earlier version of Leopard too). Testing only on a single node everything seems to work fine. When I use two nodes, one running pbs_server (and scheduler) and the other pbs_mom, all still works as long as I stay logged on in the node running the pbs_mom. As soon as I log out, the file staging (scp copy) fails.<br>

</blockquote>
<br></div>
When the file staging fails, do you see an error anywhere? What is the error? If you are not logged into the node, does the job even get submitted to pbs_mom or just rejected outright due to an authentication error?<br><font color="#888888">
<br></font></blockquote><div>&nbsp;</div></div>The error (from the returned email) is essentially due to scp failing:<br>&gt;&gt;&gt; error from copy<br>unknown user 504<br>&gt;&gt;&gt; end error output<br><br>If I do not stage-in anything then the job runs fine (irrespective of whether the authentication works properly or not) but the output stays undelivered on the momhost. If I try to stage-in any files then the failure occurs straight away. The above error is the same I get on command line if I try to scp a file from an interactive job (in the case of faulty authentication). Also, it is not enough if I am just logged into the node running the mom, the pbs_mom must have been started during the same login session. If I log out and immediately back again then the authentication is broken again.<br>
<br>errors from syslog:<br>-----------------------<br>Wed Jan&nbsp; 7 11:15:55 momhost pbs_mom[50120] &lt;Error&gt;: sys_copy, command &#39;/usr/bin/scp -rpB /var/spool/torque/spool/6.serverhost.OU username@serverhost:/Users/username/tst.o6&#39; failed with status=255, giving up after 4 attempts<br>
Wed Jan&nbsp; 7 11:15:55 momhost pbs_mom[50120] &lt;Error&gt;: req_cpyfile, Unable to copy file /var/spool/torque/spool/6.serverhost.OU to username@serverhost:/Users/username/tst.o6<br>-----------------------<br><br>