Hi All,<br><br>I am not sure if this is a torque or Maui question, so please forgive the crosspost. :}<br><br>I used to do this blissfully boringly using acl_hosts.&nbsp; Something has changed and this is not working anymore between torque 2.1.x and now.&nbsp; I have the following:<br>
<br clear="all">torque 2.3.5<br>maui 3.2.6p21<br><br>I have a large cluster with several departments and these departments want to use the nodes they purchased.&nbsp; In the past, I set up a queue for each of these departments and I assigned nodes to the queues in torque.&nbsp; Has the way to do this changed?&nbsp; I have seen several messages lately from folks no longer able to get it to work...&nbsp; <br>
I am not married to this method and will happily implement any method that will keep my (hundreds) of users separated and on their own nodes.&nbsp; I do not want them to have to change their scripts.&nbsp; These are heterogeneous, too, so it is not just a policy thing - the infiniband jobs won&#39;t run on the non IB nodes, and the some are 8proc, some are 2, etc.<br>
<br>I have tried the &quot;neednodes&quot; method.&nbsp; It did nothing.<br><br>I&#39;ve been trying to do partitions in Maui and that seems to be ignored as well.&nbsp; This is a 64 bit system, by the way.<br><br>Can anyone point me to modern documentation on how to partition the nodes?&nbsp; <br>
<br>I tried defining attributes in &quot;nodes&quot; under server_priv:<br>node74 np=2 noib<br>node75 np=2 noib<br>node76 np=2 altix<br>node77 np=8 altix<br>node78 np=8 hiio<br><br>And then I have in my torque config, something like:<br>
# Create and define esmg08q<br>create queue esmg08q<br>set queue esmg08q queue_type = Execution<br>set queue esmg08q resources_max.cput = 10000:00:00<br>set queue esmg08q resources_max.ncpus = 179<br>set queue esmg08q resources_max.nodect = 22<br>
set queue esmg08q resources_max.walltime = 10000:00:00<br>set queue esmg08q resources_min.cput = 00:00:01<br>set queue esmg08q resources_min.ncpus = 1<br>set queue esmg08q resources_min.nodect = 1<br>set queue esmg08q resources_default.neednodes=altix<br>
set queue esmg08q resources_min.walltime = 00:00:01<br>set queue esmg08q resources_default.cput = 10000:00:00<br>set queue esmg08q resources_default.ncpus = 8<br>set queue esmg08q resources_default.walltime = 100:00:00<br>
set queue esmg08q acl_logic_or = true<br>set queue esmg08q acl_groups = esmg<br>set queue esmg08q acl_groups += admin<br>set queue esmg08q acl_group_sloppy = true<br>set queue esmg08q acl_group_enable = true<br>set queue esmg08q enabled = True<br>
set queue esmg08q started = True<br><br>- From this I see in maui a line in showconfig:<br><br>maui]# /usr/local/maui/bin/showconfig | grep esmg<br>CLASSCFG[esmg08q]&nbsp; DEFAULT.FEATURES=[altix]<br><br>So I was hopeful!&nbsp; But it ignores it and doesn&#39;t assign the nodes with the altix attribute?&nbsp; No matter what I do, I always get the first nodes and in order.&nbsp; Like it is reading from a machine file that I don&#39;t know about...&nbsp; I do get 8 proc nodes if I ask for nodes with 8 processors, I do get whatever node I ask for in my submit script.&nbsp; I literally lets me request any node I want, no matter which user I am or which queue I submit to.&nbsp; Does anyone have any ideas?<br>
<br><br>Thanks all for your help.<br><br>-Jennifer Tippens<br>Really Sleepy Admin, ORNL Institutional Clusters<br><br><br><br><br><br><br><br><br>-- <br>Use it up; wear it out; make it do or do without! - L Reid<br>