Hi,<br>I am going to upgrade our torque to version 2.3.4, first i executed ./configure, and a warning show in the last:<br><br>Building components: server=yes mom=yes clients=yes<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; gui=yes drmaa=no pam=no<br>
PBS Machine type: linux<br>Remote copy: /usr/bin/scp -rpB<br>PBS home: /var/spool/torque<br>Default server: node1<br>Unix Domain sockets: yes<br>Tcl: -L/usr/lib64 -ltclx8.3 -L/usr/lib64 -ltcl8.4 -ldl -lieee -lm<br>Tk: -I/usr/X11R6/include -L/usr/lib64 -ltkx8.3 -L/usr/lib64 -ltk8.4 -L/usr/X11R6/lib64 -lX11 -L/usr/lib64 -ltclx8.3 -L/usr/lib64 -ltcl8.4 -ldl -lieee -lm<br>
<br><br>configure: WARNING: This compilation has strict compiler options enabled that cause<br>the build to fail if any compiler warnings are emitted.&nbsp; If this build fails<br>because of a harmless warning, please report the problem to <a href="mailto:torqueusers@supercluster.org">torqueusers@supercluster.org</a><br>
and run configure again with --disable-gcc-warnings.<br><br>Ready for &#39;make&#39;.<br><br>our gcc version:<br>[root@node1 torque-2.3.4]# gcc -v<br>Reading specs from /usr/lib/gcc/x86_64-redhat-linux/3.4.6/specs<br>Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-java-awt=gtk --host=x86_64-redhat-linux<br>
Thread model: posix<br>gcc version 3.4.6 20060404 (Red Hat 3.4.6-3)<br><br>Is this WARNING fatal?<br>How to solve it?<br><br>Thanks<br>-- <br>Best Wishes<br>ChenWeiguang<br>