<HTML dir=ltr><HEAD>
<META http-equiv=Content-Type content="text/html; charset=unicode">
<META content="MSHTML 6.00.2900.3395" name=GENERATOR></HEAD>
<BODY style="WORD-WRAP: break-word">
<DIV id=idOWAReplyText57434 dir=ltr>
<DIV dir=ltr><FONT face=Arial color=#000000 size=2>Worked like a charm.&nbsp; Thanks, Steve!</FONT></DIV>
<DIV dir=ltr><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV dir=ltr><FONT face=Arial size=2>--Joe</FONT></DIV></DIV>
<DIV dir=ltr><BR>
<HR tabIndex=-1>
<FONT face=Tahoma size=2><B>From:</B> Steve Young [mailto:chemadm@hamilton.edu]<BR><B>Sent:</B> Fri 10/3/2008 10:58 AM<BR><B>To:</B> Greenseid, Joseph M.<BR><B>Cc:</B> torqueusers@supercluster.org<BR><B>Subject:</B> Re: [torqueusers] assigning specific nodes to queues<BR></FONT><BR></DIV>
<DIV>Hi, 
<DIV><SPAN class=Apple-tab-span style="WHITE-SPACE: pre"></SPAN>I constrain nodes to queue's without using acl_hosts. All I do is put a feature in the server's node file like this:</DIV>
<DIV><BR></DIV>
<DIV>node01 altix</DIV>
<DIV>node02 altix</DIV>
<DIV>node03 mac</DIV>
<DIV>node04 mac</DIV>
<DIV><BR></DIV>
<DIV>then I have this in the configuration for each queue in torque:</DIV>
<DIV><BR></DIV>
<DIV>set queue altix resources_default.neednodes = altix</DIV>
<DIV><BR></DIV>
<DIV>set queue mac resources_default.neednodes = mac</DIV>
<DIV><BR></DIV>
<DIV>That seems to do it for me. Hope this helps.&nbsp;</DIV>
<DIV><BR></DIV>
<DIV>-Steve</DIV>
<DIV><BR></DIV>
<DIV><BR></DIV>
<DIV><BR>
<DIV>
<DIV>On Oct 3, 2008, at 8:48 AM, Greenseid, Joseph M. wrote:</DIV><BR class=Apple-interchange-newline>
<BLOCKQUOTE type="cite">
<DIV>
<DIV><FONT face=Arial color=#000000 size=2>
<DIV><FONT face=Arial color=#000000 size=2>
<DIV><FONT face=Arial color=#000000 size=2>hi,</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>i saw in the archives that this has been asked before, but i didn't see that there was ever resolution, so i apologize in advance for asking again if there was an i missed it.</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>i am trying to define a queue named "test," and have two nodes specifically assigned to it.&nbsp; </FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>the test queue is defined as such:</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV>
<DIV style="MARGIN: 0in 0in 0pt"><FONT face="Courier New" size=2>create queue test<BR>set queue test queue_type = Execution<BR>set queue test acl_host_enable = False<BR>set queue test acl_hosts = compute-12-13.hpcc.local<BR>set queue test acl_hosts += compute-12-12.hpcc.local<BR>set queue test resources_max.cput = 01:00:00<BR>set queue test resources_max.ncpus = 16<BR>set queue test resources_max.nodect = 2<BR>set queue test resources_max.walltime = 01:00:00<BR>set queue test resources_min.cput = 00:00:01<BR>set queue test resources_min.ncpus = 1<BR>set queue test resources_min.nodect = 1<BR>set queue test resources_min.walltime = 00:00:01<BR>set queue test resources_default.cput = 00:30:00<BR>set queue test resources_default.ncpus = 1<BR>set queue test resources_default.nodect = 1<BR>set queue test resources_default.walltime = 00:30:00<BR>set queue test resources_available.nodect = 2<BR>set queue test enabled = True<BR>set queue test started = True</FONT></DIV>
<P class=MsoPlainText style="MARGIN: 0in 0in 0pt"><FONT face="Courier New" size=2></FONT>&nbsp;</P>
<DIV style="MARGIN: 0in 0in 0pt"><FONT face=Arial size=2>however, when i try to run a job in this queue (in my job script, i specify "#PBS -q test"), it not running on either of these two nodes.&nbsp; i have tried changing the attributes of these two&nbsp;nodes in the nodes file to be of the form "compute-12-12.hpcc.local np=8 test"&nbsp;</FONT><FONT face=Arial size=2>but that didn't help, either.&nbsp; </FONT></DIV>
<P class=MsoPlainText style="MARGIN: 0in 0in 0pt"><FONT face=Arial size=2></FONT>&nbsp;</P>
<DIV style="MARGIN: 0in 0in 0pt"><FONT face=Arial size=2>i am running a slightly older version, 2.1.8, but that cannot be helped for the time being, and there was nothing in the documentation i saw that said this was specific to certain versions.&nbsp; </FONT></DIV>
<P class=MsoPlainText style="MARGIN: 0in 0in 0pt"><FONT face=Arial size=2></FONT>&nbsp;</P>
<DIV style="MARGIN: 0in 0in 0pt"><FONT face=Arial size=2>did i miss something?</FONT></DIV>
<P class=MsoPlainText style="MARGIN: 0in 0in 0pt"><FONT face=Arial size=2></FONT>&nbsp;</P>
<DIV style="MARGIN: 0in 0in 0pt"><FONT face=Arial size=2>thanks,</FONT></DIV>
<DIV style="MARGIN: 0in 0in 0pt"><FONT face=Arial size=2>--Joe</FONT></DIV></DIV></FONT></DIV></FONT></DIV></DIV>_______________________________________________<BR>torqueusers mailing list<BR><A href="mailto:torqueusers@supercluster.org">torqueusers@supercluster.org</A><BR>http://www.supercluster.org/mailman/listinfo/torqueusers<BR></BLOCKQUOTE></DIV><BR></DIV></DIV></BODY></HTML>