Hi,<br>[cwg@node1 ~] $ gcc -v<br>Reading specs from /usr/lib/gcc/x86_64-redhat-linux/3.4.6/specs<br>Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-java-awt=gtk --host=x86_64-redhat-linux<br>
Thread model: posix<br>gcc version 3.4.6 20060404 (Red Hat 3.4.6-3)<br><br>[cwg@node1 ~] $ uname -a<br>Linux node1 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:32:02 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux<br><br>[cwg@node1 ~] $ cat /proc/version <br>
Linux version 2.6.9-42.ELsmp (<a href="mailto:bhcompile@ls20-bc1-13.build.redhat.com">bhcompile@ls20-bc1-13.build.redhat.com</a>) (gcc version 3.4.6 20060404 (Red Hat 3.4.6-2)) #1 SMP Wed Jul 12 23:32:02 EDT 2006<br><br>The version of torque that i was going to install is 2.3.0, but, the last version(torque-2.1.2) was installed without compiler warnings by the same configure.<br>
<br>Thanks<br><br><div class="gmail_quote">On Mon, May 5, 2008 at 12:53 AM, Glen Beane &lt;<a href="mailto:glen.beane@gmail.com">glen.beane@gmail.com</a>&gt; wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<br><br>
<div class="gmail_quote"><div><div></div><div class="Wj3C7c">On Sat, May 3, 2008 at 9:32 PM, Weiguang Chen &lt;<a href="mailto:chenweiguang82@gmail.com" target="_blank">chenweiguang82@gmail.com</a>&gt; wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0px 0px 0px 0.8ex; padding-left: 1ex;">Hi,<br>When i am ready to upgrade the torque, a configure warning occur:<br>&quot;configure:36195: WARNING: This compilation has strict compiler options enabled that cause<br>

the build to fail if any compiler warnings are emitted.&nbsp; If this build fails<br>because of a harmless warning, please report the problem to torqueusers@superclu<br><a href="http://ster.org/" target="_blank">ster.org</a><br>

and run configure again with --disable-gcc-warnings.&quot;<br><br>I check the config.log for the last version, but not find warning like above.<br>what should i do?</blockquote>
<div>&nbsp;</div>
</div></div><div>what version of gcc do you have?&nbsp; Also can you tell me what OS you are using?&nbsp; I recently added&nbsp;a patch to trunk (2.4) that fixed some compiler warnings and I haven&#39;t patched the 2.3.x and 2.2.x branches yet.</div>

</div>
</blockquote></div><br><br clear="all"><br>-- <br>Best Wishes<br>ChenWeiguang