<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:dt="uuid:C2F41010-65B3-11d1-A29F-00AA00C14882" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">

<head>
<meta http-equiv=Content-Type content="text/html; charset=us-ascii">
<meta name=Generator content="Microsoft Word 12 (filtered medium)">
<title>RE: Rpy</title>
<style>
<!--
 /* Font Definitions */
 @font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
p
        {mso-style-priority:99;
        mso-margin-top-alt:auto;
        margin-right:0cm;
        mso-margin-bottom-alt:auto;
        margin-left:0cm;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";}
span.EmailStyle18
        {mso-style-type:personal-reply;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page Section1
        {size:612.0pt 792.0pt;
        margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.Section1
        {page:Section1;}
-->
</style>
<!--[if gte mso 9]><xml>
 <o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
 <o:shapelayout v:ext="edit">
  <o:idmap v:ext="edit" data="1" />
 </o:shapelayout></xml><![endif]-->
</head>

<body lang=EN-GB link=blue vlink=purple>

<div class=Section1>

<p style='margin-bottom:12.0pt'><span style='font-size:10.0pt;color:#1F497D'>Dear
Torque users,<o:p></o:p></span></p>

<p style='margin-bottom:12.0pt'><span style='font-size:10.0pt;color:#1F497D'>I
got the following problem from one of my users. Does anyone have experience of
this type of problem?<o:p></o:p></span></p>

<p style='margin-bottom:12.0pt'><span style='font-size:10.0pt;color:#1F497D'>I
tried running the test case on a quiet compute node to see if it would work
directly as the user did below on the admin node. There appears to be a &#8220;PATH&#8221;
error to the R command, but this is difficult to trace in the qsub environment.
Is there a way to diagnose?<o:p></o:p></span></p>

<p style='margin-bottom:12.0pt'><span style='font-size:10.0pt;color:#1F497D'>Regards,<o:p></o:p></span></p>

<p style='margin-bottom:12.0pt'><span style='font-size:10.0pt;color:#1F497D'>Tony
P.<o:p></o:p></span></p>

<p style='margin-bottom:12.0pt'><span style='font-size:10.0pt;color:#1F497D'>User
query:</span><span style='font-size:10.0pt'><br>
<br>
Today I tried to submit some new jobs on the cluster.<br>
Everything works fine, excepting R/Rpy.<br>
<br>
When I use R in one of my jobs (python scripts) an error message<br>
appears.<br>
I don't get these errors when I run the scripts on the command line<br>
without subq.<br>
<br>
For example:<br>
<br>
When I start the python Console and I use the following code, no errors.<br>
Also when I put this code in a python file and run this file without<br>
qsub (.py) no errors.<br>
-<br>
from rpy import *<br>
r.library('SparseM')<br>
-<br>
<br>
When I put this code in a python file and add it as a job it will give<br>
the following error:<br>
-<br>
Traceback (most recent call last):<br>
&nbsp; File &quot;testSP.py&quot;, line 1, in ?<br>
&nbsp;&nbsp;&nbsp; import rpy<br>
&nbsp; File &quot;/usr/lib64/python2.3/site-packages/rpy.py&quot;, line 53, in
?<br>
&nbsp;&nbsp;&nbsp; RVERSION = rpy_tools.get_R_VERSION(RHOME)<br>
&nbsp; File &quot;/usr/lib64/python2.3/site-packages/rpy_tools.py&quot;, line
98, in<br>
get_R_VERSION<br>
&nbsp;&nbsp;&nbsp; raise RuntimeError(&quot;Couldn't execute the R
interpreter&quot; +<br>
RuntimeError: Couldn't execute the R interpreter `sh: R: command not<br>
found/bin/R'.<br>
-<br>
<br>
It looks like there is someting wrong with the Path to RPY?<br>
<br>
My Jobfile includes the following code:<br>
-<br>
#PBS -j oe<br>
cd&nbsp; &quot;$PBS_O_WORKDIR&quot;<br>
python testSP.py &gt; SP.out<br>
-<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
</span><o:p></o:p></p>

</div>

</body>

</html>