<HTML>
<HEAD>
<TITLE>Re: [torqueusers] simple (I hope) /etc/hosts question</TITLE>
</HEAD>
<BODY>
<FONT FACE="Verdana, Helvetica, Arial"><SPAN STYLE='font-size:14.0px'>In $PBS_HOME/mom_priv/config<BR>
<BR>
Add the line &nbsp;$pbsserver &nbsp;&lt;name of host with pbs_server running&gt;<BR>
<BR>
<BR>
Jerry<BR>
<BR>
<BR>
<BR>
<BR>
Torque was really easy to install, but it seems like my /etc/hosts file must be screwed up, as I can't get the cluster nodes to respond. &nbsp;Specifically, within a cluster of 3 machines, each having an /etc/hosts file of: <BR>
<BR>
&nbsp;&nbsp;&nbsp;&nbsp;127.0.0.1 <a href="http://127.0.0.1">&lt;http://127.0.0.1&gt;</a> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;localhost.localdomain &nbsp;&nbsp;localhost<BR>
&nbsp;&nbsp;&nbsp;&nbsp;199.17.152.17 <a href="http://199.17.152.17">&lt;http://199.17.152.17&gt;</a> &nbsp;&nbsp;&nbsp;runner<BR>
&nbsp;&nbsp;&nbsp;&nbsp;199.17.152.135 <a href="http://199.17.152.135">&lt;http://199.17.152.135&gt;</a> &nbsp;&nbsp;muscovey <BR>
&nbsp;&nbsp;&nbsp;&nbsp;199.17.152.13 <a href="http://199.17.152.13">&lt;http://199.17.152.13&gt;</a> &nbsp;&nbsp;&nbsp;pekin<BR>
&nbsp;&nbsp;&nbsp;&nbsp;(( other workstations follow ))<BR>
<BR>
Now, when I have the pbs_server running on runner, and the pbs_mom daemons running on muscovey, pekin, and runner, I et the following status message, <BR>
<BR>
&nbsp;&nbsp;&nbsp;&nbsp;[root@runner torque-2.1.6]# pbsnodes -a<BR>
&nbsp;&nbsp;&nbsp;&nbsp;pekin<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;state = down<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;np = 1<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;ntype = cluster<BR>
<BR>
&nbsp;&nbsp;&nbsp;&nbsp;muscovey<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;state = down<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;np = 1<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;ntype = cluster <BR>
<BR>
&nbsp;&nbsp;&nbsp;&nbsp;runner<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;state = down &nbsp;&nbsp;&nbsp;<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;np = 1<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;ntype = cluster<BR>
<BR>
I realize this is a pretty low-level question, but what the heck is wrong with my /etc/hosts file?<BR>
<BR>
regards,<BR>
<BR>
NT<BR>
<BR>
<BR>
ps, &nbsp;the trouble shooting message given by torque is,<BR>
<BR>
&nbsp;&nbsp;&nbsp;&nbsp;[root@runner torque-2.1.6]# momctl -d 3<BR>
<BR>
&nbsp;&nbsp;&nbsp;&nbsp;Host: runner/runner &nbsp;&nbsp;Version: 2.1.6<BR>
&nbsp;&nbsp;&nbsp;&nbsp;WARNING: &nbsp;server not specified (set $pbsserver) <BR>
&nbsp;&nbsp;&nbsp;&nbsp;PID: &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;30531<BR>
&nbsp;&nbsp;&nbsp;&nbsp;HomeDirectory: &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;/var/spool/torque/mom_priv<BR>
&nbsp;&nbsp;&nbsp;&nbsp;MOM active: &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;2518 seconds<BR>
&nbsp;&nbsp;&nbsp;&nbsp;Server Update Interval: 45 seconds<BR>
&nbsp;&nbsp;&nbsp;&nbsp;LOGLEVEL: &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;0 (use SIGUSR1/SIGUSR2 to adjust) <BR>
&nbsp;&nbsp;&nbsp;&nbsp;Communication Model: &nbsp;&nbsp;&nbsp;RPP<BR>
&nbsp;&nbsp;&nbsp;&nbsp;TCP Timeout: &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;20 seconds<BR>
&nbsp;&nbsp;&nbsp;&nbsp;NOTE: &nbsp;no prolog configured<BR>
&nbsp;&nbsp;&nbsp;&nbsp;Alarm Time: &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;0 of 10 seconds<BR>
&nbsp;&nbsp;&nbsp;&nbsp;Trusted Client List: &nbsp;&nbsp;&nbsp;199.17.152.17 <a href="http://199.17.152.17">&lt;http://199.17.152.17&gt;</a> ,127.0.0.1 <a href="http://127.0.0.1">&lt;http://127.0.0.1&gt;</a> <BR>
&nbsp;&nbsp;&nbsp;&nbsp;Configured to use /usr/bin/scp -rpB<BR>
&nbsp;&nbsp;&nbsp;&nbsp;NOTE: &nbsp;no local jobs detected<BR>
<BR>
&nbsp;&nbsp;&nbsp;&nbsp;diagnostics complete<BR>
<BR>
<BR>
- - - - - - - &nbsp;&nbsp;- - - - - - - &nbsp;&nbsp;- - - - - - - <BR>
Nathan Moore<BR>
Assistant Professor, Physics<BR>
Winona State University<BR>
AIM: nmoorewsu <BR>
- - - - - - - &nbsp;&nbsp;- - - - - - - &nbsp;&nbsp;- - - - - - -<BR>
<HR ALIGN=CENTER SIZE="3" WIDTH="95%"></SPAN></FONT><SPAN STYLE='font-size:14.0px'><FONT FACE="Monaco, Courier New">_______________________________________________<BR>
torqueusers mailing list<BR>
torqueusers@supercluster.org<BR>
<a href="http://www.supercluster.org/mailman/listinfo/torqueusers">http://www.supercluster.org/mailman/listinfo/torqueusers</a><BR>
</FONT></SPAN>
</BODY>
</HTML>