<div>Hi Kevin,</div>
<div>&nbsp;</div>
<div>Thanks for the info.&nbsp;The&nbsp;machine is running SGI ProPack 4 SP2 with cpuset-2.0-sgi402r1. I have read thru the doc /usr/share/doc/packages/cpusets/cpuset.html, but still not really sure what to do in order to get it works with torque. It would be great if you can show me how to fix it. Thanks.
</div>
<div>&nbsp;</div>
<div>Regards,</div>
<div>Josh</div>
<div><br>&nbsp;</div>
<div><span class="gmail_quote">On 12/15/05, <b class="gmail_sendername">Kevin McMahon</b> &lt;<a href="mailto:n6965@sgi.com">n6965@sgi.com</a>&gt; wrote:</span>
<blockquote class="gmail_quote" style="PADDING-LEFT: 1ex; MARGIN: 0px 0px 0px 0.8ex; BORDER-LEFT: #ccc 1px solid"><br>Hi,<br><br>The sgi Altix cpuset API was significantly changed between<br>ProPack 3 and ProPack 4.&nbsp;&nbsp;By the errors below, it looks like your
<br>Altix system is running ProPack 4?&nbsp;&nbsp;Please confirm.<br><br>uname -a<br>cat /etc/*elease<br>rpm -qa | grep cpuset<br><br>If you are running ProPack 4, there will need to be significant<br>changes to the cpuset usage for this to work.
<br><br>Some documentations to look at:<br><br>rpm -ql cpuset<br>/usr/share/doc/packages/cpusets/cpuset.html<br><br>Kevin<br><br>==============================<br>Kevin McMahon<br>Performance and Benchmark Team<br><br>SGI Phone:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;651-683-5651
<br>SGI email:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <a href="mailto:n6965@sgi.com">n6965@sgi.com</a><br>==============================<br><br><br><br>&gt; Hi,<br>&gt;<br>&gt; I'm trying to install torque-2.0.0p3 on our SGI Altix 3700 with cpuset<br>&gt; feature, but experienced the following errors while try to compile it
<br>&gt; -&quot;make&quot;. Pls help...<br>&gt;<br>&gt; start_exec.c: In function `TMomFinalizeChild':<br>&gt; start_exec.c:1758: error: `cpuset_NameList_t' undeclared (first use in this<br>&gt; function)<br>&gt; start_exec.c:1758: error: (Each undeclared identifier is reported only once
<br>&gt; start_exec.c:1758: error: for each function it appears in.)<br>&gt; start_exec.c:1758: error: `cpusetList' undeclared (first use in this<br>&gt; function)<br>&gt; start_exec.c:1759: error: `cpuset_CPUList_t' undeclared (first use in this
<br>&gt; function)<br>&gt; start_exec.c:1759: error: `cpuList' undeclared (first use in this function)<br>&gt; start_exec.c:1760: error: `cpuset_QueueDef_t' undeclared (first use in this<br>&gt; function)<br>&gt; start_exec.c:1760: error: `cpuQdef' undeclared (first use in this function)
<br>&gt; start_exec.c:2007: error: `CPUSET_CPU_EXCLUSIVE' undeclared (first use in<br>&gt; this function)<br>&gt; start_exec.c:2007: error: `CPUSET_MEMORY_LOCAL' undeclared (first use in<br>&gt; this function)<br>&gt; make[3]: *** [start_exec.o] Error 1
<br>&gt; make[3]: Leaving directory `/tmp/torque-2.0.0p3/src/resmom'<br>&gt; make[2]: *** [all] Error 2<br>&gt; make[2]: Leaving directory `/tmp/torque-2.0.0p3/src/resmom'<br>&gt; make[1]: *** [all] Error 2<br>&gt; make[1]: Leaving directory `/tmp/torque-
2.0.0p3/src'<br>&gt; make: *** [all] Error 2<br>&gt;<br>&gt; Thanks.<br>&gt; --<br>&gt; Josh<br>&gt;<br>&gt; ------=_Part_2494_8819629.1134652495356<br>&gt; Content-Type: text/html; charset=ISO-8859-1<br>&gt; Content-Transfer-Encoding: quoted-printable
<br>&gt; Content-Disposition: inline<br>&gt;<br>&gt; &lt;div&gt;Hi,&lt;/div&gt;<br>&gt; &lt;div&gt;&amp;nbsp;&lt;/div&gt;<br>&gt; &lt;div&gt;I'm trying to install torque-2.0.0p3 on our SGI Altix 3700 with cpuset=<br>&gt;&nbsp;&nbsp;feature, but experienced the following errors while try to compile it -&amp;qu=
<br>&gt; ot;make&amp;quot;. Pls help... &lt;/div&gt;<br>&gt; &lt;div&gt;&amp;nbsp;&lt;/div&gt;<br>&gt; &lt;div&gt;start_exec.c: In function `TMomFinalizeChild':&lt;br&gt;start_exec.c:1758: e=<br>&gt; rror: `cpuset_NameList_t' undeclared (first use in this function)&lt;br&gt;start_=
<br>&gt; exec.c:1758: error: (Each undeclared identifier is reported only once&lt;br&gt;<br>&gt; start_exec.c:1758: error: for each function it appears in.)&lt;br&gt;start_exec.c=<br>&gt; :1758: error: `cpusetList' undeclared (first use in this function)&lt;br&gt;start=
<br>&gt; _exec.c:1759: error: `cpuset_CPUList_t' undeclared (first use in this funct=<br>&gt; ion)<br>&gt; &lt;br&gt;start_exec.c:1759: error: `cpuList' undeclared (first use in this funct=<br>&gt; ion)&lt;br&gt;start_exec.c:1760: error: `cpuset_QueueDef_t' undeclared (first use=
<br>&gt;&nbsp;&nbsp;in this function)&lt;br&gt;start_exec.c:1760: error: `cpuQdef' undeclared (first=<br>&gt;&nbsp;&nbsp;use in this function)<br>&gt; &lt;br&gt;start_exec.c:2007: error: `CPUSET_CPU_EXCLUSIVE' undeclared (first use =<br>&gt; in this function)&lt;br&gt;start_exec.c:2007: error: `CPUSET_MEMORY_LOCAL' undecl=
<br>&gt; ared (first use in this function)&lt;br&gt;make[3]: *** [start_exec.o] Error 1<br>&gt; &lt;br&gt;make[3]: Leaving directory `/tmp/torque-2.0.0p3/src/resmom'&lt;br&gt;make[2]:=<br>&gt;&nbsp;&nbsp;*** [all] Error 2&lt;br&gt;make[2]: Leaving directory `/tmp/torque-
2.0.0p3/src/r=<br>&gt; esmom'&lt;br&gt;make[1]: *** [all] Error 2&lt;br&gt;make[1]: Leaving directory `/tmp/to=<br>&gt; rque-<br>&gt; 2.0.0p3/src'&lt;br&gt;make: *** [all] Error 2&lt;br clear=3D&quot;all&quot;&gt;&lt;/div&gt;
<br>&gt; &lt;div&gt;&amp;nbsp;&lt;/div&gt;<br>&gt; &lt;div&gt;Thanks.&lt;br&gt;-- &lt;br&gt;Josh &lt;/div&gt;<br>&gt;<br>&gt; ------=_Part_2494_8819629.1134652495356--<br>&gt;<br>&gt; --===============0318427104==<br>&gt; Content-Type: text/plain; charset=&quot;us-ascii&quot;
<br>&gt; MIME-Version: 1.0<br>&gt; Content-Transfer-Encoding: 7bit<br>&gt; Content-Disposition: inline<br>&gt;<br>&gt; _______________________________________________<br>&gt; torqueusers mailing list<br>&gt; <a href="mailto:torqueusers@supercluster.org">
torqueusers@supercluster.org</a><br>&gt; <a href="http://www.supercluster.org/mailman/listinfo/torqueusers">http://www.supercluster.org/mailman/listinfo/torqueusers</a><br>&gt;<br>&gt; --===============0318427104==--<br>&gt;
<br><br></blockquote></div><br><br clear="all"><br>-- <br>Josh