<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"><HTML DIR=ltr><HEAD><META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1"></HEAD><BODY><DIV><FONT face="Courier New" color=#000000 >Hello:</FONT></DIV>
<DIV><FONT face="Courier New"></FONT>&nbsp;</DIV>
<DIV><FONT face="Courier New">It seems that starting from Torque v1.2.0p1, the 
Makefile for xpbsmon was modified such that the resulting xpbsmon no longer 
works:</FONT></DIV>
<DIV><FONT face="Courier New"></FONT>&nbsp;</DIV>
<DIV><FONT face="Courier New">-bash: ./xpbsmon: ../pbs_wish: bad interpreter: No 
such file or directory</FONT></DIV>
<DIV><FONT face="Courier New"></FONT>&nbsp;</DIV>
<DIV><FONT face="Courier New">This is what the first line of xpbsmon looks 
like:</FONT></DIV>
<P><FONT face="Courier New">#!../pbs_wish -f</FONT></P>
<DIV><FONT face="Courier New">It should really read:</FONT></DIV>
<DIV><FONT face="Courier New"></FONT>&nbsp;</DIV>
<DIV><FONT face="Courier New">#!{PBSROOT}/bin/pbs_wish -f</FONT></DIV>
<DIV><FONT face="Courier New"></FONT>&nbsp;</DIV>
<DIV><FONT face="Courier New">The diff for the Makefile from src/tools/xpbsmon 
between 1.2.0p0 and 1.2.0p1 is as follows:</FONT></DIV>
<P><FONT 
face="Courier New">359,362c357<BR>&lt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; sed 
-e 's,#\!.*pbs_wish.*$$,#\!$(PBS_UBIN)/pbs_wish -f,' 
\<BR>&lt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; -e 
's,set&nbsp; *libdir.*$$,set libdir ${XPBSMON_LIB},' 
\<BR>&lt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; -e 
's,set&nbsp; *appdefdir.*$$,set appdefdir ${XPBSMON_LIB},' 
\<BR>&lt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; xpbsmon 
&gt; $(bindir)/xpbsmon</FONT></P>
<DIV><FONT face="Courier New">Is this a known issue?</FONT></DIV>
<DIV><FONT face="Courier New"></FONT>&nbsp;</DIV>
<DIV><FONT face="Courier New">Thanks,</FONT></DIV>
<DIV><FONT face="Courier New"></FONT>&nbsp;</DIV>
<DIV><FONT face="Courier New">Bernard</FONT></DIV></BODY></HTML>