Roy,<div><br></div><div>Have you tried starting the nodes with an alias? pbs_mom -A &lt;node_name&gt;</div><div><br></div><div>David<br><br><div class="gmail_quote">On Tue, May 8, 2012 at 8:00 AM,  <span dir="ltr">&lt;<a href="mailto:bugzilla-daemon@supercluster.org" target="_blank">bugzilla-daemon@supercluster.org</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><a href="http://www.clusterresources.com/bugzilla/show_bug.cgi?id=191" target="_blank">http://www.clusterresources.com/bugzilla/show_bug.cgi?id=191</a><br>

<br>
           Summary: pbsdsh doesn&#39;t work if nodename differs from hostname.<br>
           Product: TORQUE<br>
           Version: 4.0.*<br>
          Platform: PC<br>
        OS/Version: Linux<br>
            Status: NEW<br>
          Severity: normal<br>
          Priority: P5<br>
         Component: pbs_mom<br>
        AssignedTo: <a href="mailto:knielson@adaptivecomputing.com">knielson@adaptivecomputing.com</a><br>
        ReportedBy: <a href="mailto:roy.dragseth@uit.no">roy.dragseth@uit.no</a><br>
                CC: <a href="mailto:torquedev@supercluster.org">torquedev@supercluster.org</a><br>
   Estimated Hours: 0.0<br>
<br>
<br>
If pbs_mom is started with a name that differs from the hostname pbsdsh stops<br>
working across multiple nodes.<br>
<br>
My setup has compute nodes with hostnames like compute-X-Y.local and node names<br>
in torque where the .local domain is dropped so the hostlist has entries like<br>
compute-X-Y.<br>
<br>
This used to work fine in torque 2 and 3, but on torque 4.0.1 this will make<br>
pbsdsh hang indefinitely (and any mpi launcher using libtm).<br>
<br>
Is it possible to have the old behaviour back?<br>
<br>
Regards,<br>
Roy.<br>
<span class="HOEnZb"><font color="#888888"><br>
--<br>
Configure bugmail: <a href="http://www.clusterresources.com/bugzilla/userprefs.cgi?tab=email" target="_blank">http://www.clusterresources.com/bugzilla/userprefs.cgi?tab=email</a><br>
------- You are receiving this mail because: -------<br>
You are on the CC list for the bug.<br>
_______________________________________________<br>
torquedev mailing list<br>
<a href="mailto:torquedev@supercluster.org">torquedev@supercluster.org</a><br>
<a href="http://www.supercluster.org/mailman/listinfo/torquedev" target="_blank">http://www.supercluster.org/mailman/listinfo/torquedev</a><br>
</font></span></blockquote></div><br><br clear="all"><div><br></div>-- <br><div>David Beer | Software Engineer</div><div>Adaptive Computing</div><br>
</div>