There was a similar post earlier : <a href="http://www.clusterresources.com/pipermail/mauiusers/2009-July/003930.html">http://www.clusterresources.com/pipermail/mauiusers/2009-July/003930.html</a><br><br>But did not find any response to it. Can anyone please provide some ideas / suggestion on this issue.<br>

<br>Thanks,<br>Kunal<br><br><div class="gmail_quote">On Wed, May 23, 2012 at 2:26 PM, Kunal Rao <span dir="ltr">&lt;<a href="mailto:kunalgrao@gmail.com" target="_blank">kunalgrao@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0pt 0pt 0pt 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">

Hello,<br><br>I have a 10 node cluster. There are 3 jobs. 1 which needs 2 nodes ( with 1 task per node ), another which needs 4 nodes (with 1 task per node) and the third one which needs 4 nodes (  with 2 task on 1 node and 1 task each on the other 3 nodes ).<br>


<br>Additional configuration in maui.cfg is :<br><br>BACKFILLPOLICY        FIRSTFIT<br>RESERVATIONPOLICY     CURRENTHIGHEST<br><br>ENABLEMULTIREQJOBS TRUE<br>NODEALLOCATIONPOLICY  MINRESOURCE<br>NODEACCESSPOLICY SINGLEJOB<br>


JOBNODEMATCHPOLICY EXACTNODE<br><br>I am observing that if the first 2 jobs are running, the third one does not start ( even though 4 nodes are available ) until 1 of the jobs complete. With checkjob -v &lt;job_id&gt; it shows the following output :<br>


<br>------------------<br><br>checking job 5791 (RM job &#39;5791.fire16.csa.local&#39;)<br><br>State: Idle<br>Creds:  user:kunal  group:kunal  class:batch  qos:DEFAULT<br>WallTime: 00:00:00 of 00:04:51<br>SubmitTime: Wed May 23 11:52:04<br>


  (Time Queued  Total: 00:48:52  Eligible: 00:48:52)<br><br>StartDate: 00:00:01  Wed May 23 12:40:57<br>Total Tasks: 2<br><br>Req[0]  TaskCount: 2  Partition: ALL<br>Network: [NONE]  Memory &gt;= 0  Disk &gt;= 0  Swap &gt;= 0<br>


Opsys: [NONE]  Arch: [NONE]  Features: [NONE]<br>Exec:  &#39;&#39;  ExecSize: 0  ImageSize: 0<br>Dedicated Resources Per Task: PROCS: 1<br>NodeAccess: SINGLEJOB<br>TasksPerNode: 2  NodeCount: 1<br><br>Req[1]  TaskCount: 3  Partition: ALL<br>


Network: [NONE]  Memory &gt;= 0  Disk &gt;= 0  Swap &gt;= 0<br>Opsys: [NONE]  Arch: [NONE]  Features: [NONE]<br>Exec:  &#39;&#39;  ExecSize: 0  ImageSize: 0<br>Dedicated Resources Per Task: PROCS: 1<br>NodeAccess: SINGLEJOB<br>


NodeCount: 3<br><br><br>IWD: [NONE]  Executable:  [NONE]<br>Bypass: 5  StartCount: 0<br>PartitionMask: [ALL]<br>Flags:       RESTARTABLE<br><br>Reservation &#39;5791&#39; (00:00:01 -&gt; 00:04:52  Duration: 00:04:51)<br>

PE:  5.00  StartPriority:  48<br>
cannot select job 5791 for partition DEFAULT (startdate in &#39;00:00:01&#39;)<br><br>------------<br><br>What could be the reason for not starting this job ? How do I resolve this ?<br><br>Thanks,<br>Kunal<br>
</blockquote></div><br>