<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head><body><div style="font-family:tahoma, new york, times, serif;font-size:12pt">&gt;that depends - how did you install torque/maui in the first place?<BR>&gt;Did you compile frome source, or install a package from some distro?<BR>
<DIV></DIV>
<DIV>I installed from source using this guide <A href="http://debianclusters.org/index.php/Resource_Manager:_Torque">http://debianclusters.org/index.php/Resource_Manager:_Torque</A><BR>I didn't configured for sendmail :(</DIV>
<DIV>&nbsp;</DIV>
<DIV>&gt;according to the changelog, logging of email events was introduced in torque-2.4.4</DIV>
<DIV>No I have the latest version 3.0.0</DIV>
<DIV>&nbsp;</DIV>
<DIV>&gt;What operating system are you using by the way?<BR>Ubuntu server 10.04</DIV>
<DIV>&nbsp;</DIV>
<DIV>&gt;&nbsp;Where is your sendmail actually installed? Traditionally it was always at <BR>&gt;/usr/lib/sendmail so if your operating system has put it into /usr/sbin, <BR>&gt;then you may find putting in a symlink in /usr/lib to /usr/sbin/sendmail <BR>&gt;so that Torque finds it in the expected place might be the solution:<BR><A href="mailto:mahmood@svr1">mahmood@svr1</A>:~# which sendmail<BR>/usr/sbin/sendmail<BR>If you see the log message below, it doen't complain about sendmail binary. It seems that it finds the binary but the problem is somewhere else<BR></DIV>
<DIV>&gt;Have you had a look at the sendmail log? Typically this is /var/log/mail.log or /var/log/maillog for <SPAN style="BORDER-BOTTOM: #366388 2px dotted; CURSOR: hand" id=lw_1294759794_1 class=yshortcuts>Linux</SPAN> and <SPAN id=lw_1294759794_2 class=yshortcuts>FreeBSD</SPAN> and &gt;under Solaris, sendmail logging by default goes into /var/log/syslog.<BR>I ran again using my gmail address (since I am sure that from server I can send emails to my gmail account). This the /var/log/mail.info (please note that if you see "<U><FONT color=#0066cc>@gmail.com</FONT></U>", that is my gmail address and I removed it for spammers!)</DIV>
<DIV>&nbsp;</DIV>
<DIV><SPAN lang=EN>
<P>Jan 11 19:30:32 svr1 sendmail[23931]: unable to qualify my own domain name (svr1) -- using short name</P>
<P>Jan 11 19:30:32 svr1 sendmail[23935]: unable to qualify my own domain name (svr1) -- using short name</P>
<P>Jan 11 19:30:32 svr1 sendmail[23931]: p0BG0W7n023931: from=adm, size=148, class=0, nrcpts=1, msgid=&lt;201101111600.p0BG0W7n023931@svr1&gt;, relay=root@localhost</P>
<P>Jan 11 19:30:32 svr1 sendmail[23935]: p0BG0W91023935: from=adm, size=276, class=0, nrcpts=1, msgid=&lt;201101111600.p0BG0W91023935@svr1&gt;, relay=root@localhost</P>
<P>Jan 11 19:30:32 svr1 sm-mta[24589]: p0BG0WOj024589: from=&lt;adm@svr1&gt;, size=516, class=0, nrcpts=1, msgid=&lt;201101111600.p0BG0W91023935@svr1&gt;, proto=ESMTP, daemon=MTA-v4, relay=localhost [127.0.0.1]</P>
<P>Jan 11 19:30:32 svr1 sm-mta[24588]: p0BG0W5v024588: from=&lt;adm@svr1&gt;, size=388, class=0, nrcpts=1, msgid=&lt;201101111600.p0BG0W7n023931@svr1&gt;, proto=ESMTP, daemon=MTA-v4, relay=localhost [127.0.0.1]</P>
<P>Jan 11 19:30:32 svr1 sendmail[23935]: p0BG0W91023935: <A href="mailto:to=@gmail.com">to=@gmail.com</A>, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30276, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (p0BG0WOj024589 Message accepted for delivery)</P>
<P>Jan 11 19:30:32 svr1 sendmail[23931]: p0BG0W7n023931: <A href="mailto:to=@gmail.com">to=@gmail.com</A>, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30148, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (p0BG0W5v024588 Message accepted for delivery)</P>
<P>Jan 11 19:30:58 svr1 sm-mta[24593]: p0BG0W5v024588: to=&lt;@gmail.com&gt;, delay=00:00:26, xdelay=00:00:26, mailer=esmtp, pri=120388, relay=alt4.gmail-smtp-in.l.google.com. [209.85.227.27], dsn=4.0.0, stat=Deferred: alt4.gmail-smtp-in.l.google.com.: No route to host</P>
<P>Jan 11 19:31:11 svr1 sm-mta[24591]: p0BG0WOj024589: to=&lt;@gmail.com&gt;, delay=00:00:39, xdelay=00:00:39, mailer=esmtp, pri=120516, relay=alt4.gmail-smtp-in.l.google.com. [209.85.227.27], dsn=4.0.0, stat=Deferred: alt4.gmail-smtp-in.l.google.com.: No route to host</P>
<P>&nbsp;</P>
<P>Thanks in advance,</P></SPAN></DIV>
<DIV>
<DIV><FONT style="BACKGROUND-COLOR: #ffffff" color=#0080ff size=2 face="arial, helvetica, sans-serif"><STRONG>// Naderan *Mahmood;</STRONG></FONT></DIV></DIV>
<DIV><BR></DIV>
<DIV style="FONT-FAMILY: tahoma, new york, times, serif; FONT-SIZE: 12pt"><BR>
<DIV style="FONT-FAMILY: tahoma, new york, times, serif; FONT-SIZE: 12pt"><FONT size=2 face=Tahoma>
<HR SIZE=1>
<B><SPAN style="FONT-WEIGHT: bold">From:</SPAN></B> Burkhard Bunk &lt;bunk@physik.hu-berlin.de&gt;<BR><B><SPAN style="FONT-WEIGHT: bold">To:</SPAN></B> Mahmood Naderan &lt;nt_mahmood@yahoo.com&gt;<BR><B><SPAN style="FONT-WEIGHT: bold">Cc:</SPAN></B> maui &lt;mauiusers@supercluster.org&gt;<BR><B><SPAN style="FONT-WEIGHT: bold">Sent:</SPAN></B> Tue, January 11, 2011 7:04:15 PM<BR><B><SPAN style="FONT-WEIGHT: bold">Subject:</SPAN></B> Re: [Mauiusers] no email is received<BR></FONT><BR>Hi,<BR><BR>that depends - how did you install torque/maui in the first place?<BR>Did you compile frome source, or install a package from some distro?<BR><BR>BTW, this has nothing to do with Maui anyway.<BR><BR>Regards,<BR>Burkhard Bunk.<BR>----------------------------------------------------------------------<BR><A href="mailto:bunk@physik.hu-berlin.de" ymailto="mailto:bunk@physik.hu-berlin.de">bunk@physik.hu-berlin.de</A>&nbsp; &nbsp; &nbsp; Physics Institute, Humboldt
 University<BR>fax:&nbsp; &nbsp; ++49-30 2093 7628&nbsp; &nbsp; Newtonstr. 15<BR>phone:&nbsp; ++49-30 2093 7980&nbsp; &nbsp; 12489 Berlin, Germany<BR>----------------------------------------------------------------------<BR><BR>On Tue, 11 Jan 2011, Mahmood Naderan wrote:<BR><BR>&gt; &gt;(1) The firewall of your institution may prohibit sending mail directly<BR>&gt; &gt;&nbsp;&nbsp;&nbsp; to the outside world. Try with a local email address.<BR>&gt; I don't think about this case. I have a python script which send an email to<BR>&gt; my gmail address.<BR>&gt; <BR>&gt; &gt;(2) Torque may be unable to find sendmail.<BR>&gt; &gt;&nbsp;&nbsp;&nbsp; I found that it is necessary to compile torque with the full<BR>&gt; &gt;&nbsp;&nbsp;&nbsp; pathname of sendmail:<BR>&gt; &gt;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; configure --with-sendmail=/usr/sbin/sendmail ...<BR>&gt; &gt;&nbsp;&nbsp;&nbsp; to get it working.<BR>&gt; No.... :o Then I have to do&nbsp;everything
 (create queue), maui and torque<BR>&gt; configs, nodes and&nbsp;....&nbsp;from scratch??<BR>&gt; &nbsp;<BR>&gt; // Naderan *Mahmood;<BR>&gt; <BR>&gt; <BR>&gt; _____________________________________________________________________________________<BR>&gt; From: Burkhard Bunk &lt;<A href="mailto:bunk@physik.hu-berlin.de" ymailto="mailto:bunk@physik.hu-berlin.de">bunk@physik.hu-berlin.de</A>&gt;<BR>&gt; To: Mahmood Naderan &lt;<A href="mailto:nt_mahmood@yahoo.com" ymailto="mailto:nt_mahmood@yahoo.com">nt_mahmood@yahoo.com</A>&gt;<BR>&gt; Cc: maui &lt;<A href="mailto:mauiusers@supercluster.org" ymailto="mailto:mauiusers@supercluster.org">mauiusers@supercluster.org</A>&gt;<BR>&gt; Sent: Tue, January 11, 2011 6:44:40 PM<BR>&gt; Subject: Re: [Mauiusers] no email is received<BR>&gt; <BR>&gt; Hi,<BR>&gt; <BR>&gt; two ideas:<BR>&gt; <BR>&gt; (1) The firewall of your institution may prohibit sending mail directly<BR>&gt; &nbsp;&nbsp;&nbsp; to the outside world. Try
 with a local email address.<BR>&gt; <BR>&gt; (2) Torque may be unable to find sendmail.<BR>&gt; &nbsp;&nbsp;&nbsp; I found that it is necessary to compile torque with the full<BR>&gt; &nbsp;&nbsp;&nbsp; pathname of sendmail:<BR>&gt; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; configure --with-sendmail=/usr/sbin/sendmail ...<BR>&gt; &nbsp;&nbsp;&nbsp; to get it working.<BR>&gt; <BR>&gt; Regards,<BR>&gt; Burkhard Bunk.<BR>&gt; ----------------------------------------------------------------------<BR>&gt; <A href="mailto:bunk@physik.hu-berlin.de" ymailto="mailto:bunk@physik.hu-berlin.de">bunk@physik.hu-berlin.de</A>&nbsp; &nbsp; &nbsp; Physics Institute, Humboldt University<BR>&gt; fax:&nbsp; &nbsp; ++49-30 2093 7628&nbsp; &nbsp; Newtonstr. 15<BR>&gt; phone:&nbsp; ++49-30 2093 7980&nbsp; &nbsp; 12489 Berlin, Germany<BR>&gt; ----------------------------------------------------------------------<BR>&gt; <BR>&gt; On Tue, 11 Jan 2011, Mahmood Naderan wrote:<BR>&gt;
 <BR>&gt; &gt; Hi,<BR>&gt; &gt; In my script&nbsp;I&nbsp;have:<BR>&gt; &gt; #PBS -m abe<BR>&gt; &gt; #PBS -M <A href="mailto:nt_mahmood@.....com" ymailto="mailto:nt_mahmood@.....com">nt_mahmood@.....com</A><BR>&gt; &gt; which is my&nbsp;yahoo address. The problem is&nbsp;I don't receive any email. The<BR>&gt; &gt; sendmail is installed on the server. Any idea about that?<BR>&gt; &gt; &nbsp;<BR>&gt; &gt; // Naderan *Mahmood;<BR>&gt; &gt;<BR>&gt; &gt;<BR>&gt; &gt;<BR>&gt; <BR>&gt; <BR>&gt;</DIV></DIV></div><br>

      </body></html>