<HTML dir=ltr><HEAD>
<META http-equiv=Content-Type content="text/html; charset=unicode">
<META content="MSHTML 6.00.6000.17023" name=GENERATOR></HEAD>
<BODY>
<DIV><FONT face=Arial color=#000000 size=2>Hi all,</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>First off, let me say I'm not sure if this is a Torque or Maui question.&nbsp; </FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>I am setting up a system that is going to be running lots of small jobs (each job will likely&nbsp;be 8 or 16 cores, &lt;&nbsp;7 seconds in length).&nbsp; The time it takes to complete a job is critical, as there is a requirement for a whole workflow (in which the job&nbsp;execution is the largest step, but not the only one)&nbsp;to take&nbsp;10 seconds, so we've been doing timing tests.&nbsp; I was using Maui's logs to see when jobs got queued, when they started execution, and when they finished execution.&nbsp; I was then comparing that to the output of running the `time` command against my mpirun command inside the script.&nbsp; On average, it takes about 2 extra seconds on top of the actual command being run for the scheduler/queue to do&nbsp;their thing.&nbsp; I'm guessing at least part of this is that something is polling every second or something like that.&nbsp; Is that something that I might be able to tune down to a smaller value?&nbsp; If that's not it, are there any other suggestions to get this time down as much as possible?</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>I know under normal circumstances, with jobs that run for hours and days, these&nbsp;amounts of time get lost in the noise,&nbsp;so I'd never thought about squeezing an extra second out of the system in this way before.&nbsp; </FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>Thanks,</FONT></DIV>
<DIV><FONT face=Arial size=2>--Joe</FONT></DIV></BODY></HTML>