Hi Maui Users,<br>I am new to Maui. I have the same problem too. I use<br>NODEACCESSPOLICY        SINGLEJOB<br>NODEALLOCATIONPOLICY  MINRESOURCE<br><br>My clusters are multi-core Nodes. Some jobs will use multiple cores, some do not. I wish the policy is, allocating the new job idle nodes first, if there are no idle nodes, then allocating it the available partially free nodes, last put it in queues . When I use pbs_sched, it is easier to set set server node_pack = False, and everything works fine. Using Maui with NODEACCESSPOLICY SINGLEJOB setting, Every nodes ONLY runs 1 job. How should I do to adjust the maui policy to fulfill the objective?<br>
Thanks in advance,<br><br>ZZ <br><br><div class="gmail_quote"><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><br>
Hello,<br>
<br>
we&#39;d like to submit jobs on a load balanced basis. We set<br>
NODEALLOCATIONPOLICY to CPULOAD.<br>
When we submit a job and there are enough fully free nodes, then<br>
everything is ok, the job is running. But if there aren&#39;t enough fully<br>
free nodes - only partially free nodes are available, the job doesn&#39;t<br>
run. It is in the idle state.<br>
<br>
For example:<br>
A job requests -l nodes=4:ppn=3<br>
Available nodes (every node has 8 CPUs):<br>
Nodes#    Free CPUs<br>
r1i1n4#    4<br>
r1i1n5#    3<br>
r1i1n7#    6<br>
r1i1n8#    2<br>
r1i1n9#    2<br>
r1i1n12#    3<br>
r1i1n13#    3<br>
r1i1n15#    3<br>
<br>
The requested resources are available, but the job doesn&#39;t run.<br>
<br>
The output of checkjob 8970:<br>
<br>
State: Idle<br>
Creds: user:black group:users class:batch qos:DEFAULT<br>
WallTime: 00:00:00 of 41:16:00:00<br>
SubmitTime: Thu Jun 11 15:01:53<br>
(Time Queued Total: 00:16:26 Eligible: 00:16:26)<br>
<br>
StartDate: 00:00:01 Thu Jun 11 15:18:20<br>
Total Tasks: 12<br>
<br>
Req[0] TaskCount: 12 Partition: ALL<br>
Network: [NONE] Memory &gt;= 0 Disk &gt;= 0 Swap &gt;= 0<br>
Opsys: [NONE] Arch: [NONE] Features: [batch]<br>
<br>
IWD: [NONE] Executable: NONE]<br>
Bypass: 0 StartCount: 0<br>
PartitionMask: [ALL]<br>
Flags: RESTARTABLE<br>
<br>
Reservation &#39;8970&#39; (00:00:01 -&gt; 41:16:00:01 Duration: 41:16:00:00)<br>
PE: 12.00 StartPriority: 16<br>
cannot select job 8970 for partition DEFAULT (startdate in &#39;00:00:01&#39;)<br>
<br>
We changed NODEALLOCATIONPOLICY from CPULOAD to MINRESOURCES and the job<br>
started immediately. But we&#39;d like to use load balance.<br>
<br>
Any suggestion?<br>
<br>
Thank you.<br>
<br>
Best regards<br>
<br>
Jana Uhlirova<br></blockquote></div><br>