Did you this?<br><br>su -c &quot;gmkuser -d \&quot;Maui Scheduler\&quot; maui&quot; gold<br>su -c &quot;goldsh RoleUser Create Role=Scheduler Name=maui&quot; gold<br><br>But it looks like you&#39;re running maui as root, so s/maui/root/ in the above.
<br><br>Doubt it makes a difference, but you have a typo, &quot;<font face="Arial" size="2">JOBFAILUREACTION=NON&quot;. I think you meant NONE.<br><br>Kevin<br></font><br><div><span class="gmail_quote">On 1/29/07, <b class="gmail_sendername">
Carlson, Timothy S</b> &lt;<a href="mailto:Timothy.Carlson@pnl.gov">Timothy.Carlson@pnl.gov</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">







<div>


<p><font face="Arial" size="2">Here is my setup.</font>
</p>

<p><font face="Arial" size="2">I would like to integrate Maui/Gold/Torque on an IRIX64 running IRIX 6.5.30. I&#39;ve got everything compiled and running with the IRIX compilers and I can submit a job without a </font></p>


<p><font face="Arial" size="2">#PBS -A myaccount</font>
</p>

<p><font face="Arial" size="2">line and thins runs fine. However when I add in a #PBS -A line, my jobs exits without running&nbsp; and I get the following in my torque output file.</font></p>

<p><font face="Arial" size="2">mom_close_poll: entered</font>
</p>

<p><font face="Arial" size="2">And I get an email message of</font>
</p>

<p><font face="Courier New" size="2">PBS Job Id: 4.nwvisus</font>

<br><font face="Courier New" size="2">Job Name:&nbsp;&nbsp; test</font>

<br><font face="Courier New" size="2">Aborted by PBS Server</font>

<br><font face="Courier New" size="2">Job cannot be executed</font>

<br><font face="Courier New" size="2">See job standard error file</font>
</p>

<p><font face="Arial" size="2">The maui logs seem to indicate that gold was queried and in fact a charge was made after the job has run.</font>
</p>

<p><font face="Arial" size="2">INFO:&nbsp;&nbsp;&nbsp;&nbsp; response received from server</font>

<br><font face="Arial" size="2">INFO:&nbsp;&nbsp;&nbsp;&nbsp; response received: &#39;&lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8&quot;?&gt;</font>

<br><font face="Arial" size="2">&lt;Envelope&gt;&lt;Body&gt;&lt;Response actor=&quot;root&quot;&gt;&lt;Status&gt;&lt;Value&gt;Success&lt;/Value&gt;&lt;Code&gt;000&lt;/Code&gt;&lt;Message&gt;Successfully charged job 4 for 62 credits 1 reservations were removed&lt;/Message&gt;&lt;/Status&gt;&lt;Count&gt;62&lt;/Count&gt;&lt;Data&gt;&lt;Charge&gt;&lt;Amount&gt;62&lt;/Amount&gt;&lt;Job&gt;174840&lt;/Job&gt;&lt;/Charge&gt;&lt;/Data&gt;&lt;/Response&gt;&lt;/Body&gt;&lt;/Envelope&gt;
</font></p>

<p><font face="Arial" size="2">&#39;</font>

<br><font face="Arial" size="2">MSUDisconnect(S)</font>

<br><font face="Arial" size="2">INFO:&nbsp;&nbsp;&nbsp;&nbsp; command response &#39;&lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8&quot;?&gt;</font>

<br><font face="Arial" size="2">&lt;Envelope&gt;&lt;Body&gt;&lt;Response actor=&quot;root&quot;&gt;&lt;Status&gt;&lt;Value&gt;Success&lt;/Value&gt;&lt;Code&gt;000&lt;/Code&gt;&lt;Message&gt;Successfully charged job 4 for 62 credits
</font></p>

<p><font face="Arial" size="2">1 reservations were removed&lt;/Message&gt;&lt;/Status&gt;&lt;Count&gt;62&lt;/Count&gt;&lt;Data&gt;&lt;Charge&gt;&lt;Amount&gt;62&lt;/Amount&gt;&lt;Job&gt;174840&lt;/Job&gt;&lt;/Charge&gt;&lt;/Data&gt;&lt;/Response&gt;&lt;/Body&gt;&lt;/Envelope&gt;
</font></p>

<p><font face="Arial" size="2">&#39;</font>
</p>

<p><font face="Arial" size="2">However, in the logs before that I see where there were problems contacting the resource manager. Not sure if this is normal or not</font></p>

<p><font face="Arial" size="2">ERROR:&nbsp;&nbsp;&nbsp; cannot receive response from allocation-manager server &#39;dbserver&#39;:7112</font>

<br><font face="Arial" size="2">MSysRegEvent(FAILURE:&nbsp; cannot receive response from allocation-manager server dbserver:7112 (cmd: &#39;&lt;XML&gt;&#39;)</font>

<br><font face="Arial" size="2">,0,0,1)</font>

<br><font face="Arial" size="2">MSysLaunchAction(ASList,1)</font>

<br><font face="Arial" size="2">INFO:&nbsp;&nbsp;&nbsp;&nbsp; command response &#39;NULL&#39;</font>

<br><font face="Arial" size="2">ALERT:&nbsp;&nbsp;&nbsp; no job data available</font>

<br><font face="Arial" size="2">ALERT:&nbsp;&nbsp;&nbsp; cannot extract status</font>

<br><font face="Arial" size="2">ALERT:&nbsp;&nbsp;&nbsp; cannot reserve allocation for job</font>

<br><font face="Arial" size="2">WARNING:&nbsp; cannot reserve allocation for job &#39;4&#39;, reason: BankFailure</font>

<br><font face="Arial" size="2">MRMJobStart(4,Msg,SC)</font>

<br><font face="Arial" size="2">MPBSJobStart4,nwvisus,Msg,SC)</font>

<br><font face="Arial" size="2">MPBSJobModify4,Resource_List,Resource,nwvisus:ppn=2)</font>

<br><font face="Arial" size="2">MPBSJobModify(4,Resource_List,Resource,1:ppn=2)</font>
</p>
<br>
<br>

<p><font face="Arial" size="2">I built both Torque-2.1.6 and Maui-2.6.18 in 64 bit mode and fixed the configure problem in Torque so that the linker tried to link 64 bit and add the -D__M64 to the OSCCFLAGS of Maui.&nbsp; I&#39;ve also tried 
Torque-2.0.0pXX and snapshot version of Maui. All of this with gold-2.0.0.7</font></p>

<p><font face="Arial" size="2">I can query my gold database with basic gold commands from this machine and I&#39;m fairly sure I have&nbsp; configured my maui.cfg maui-private.cfg file correctly </font></p>

<p><font face="Arial" size="2">maui.cfg</font>
</p>

<p><font face="Arial" size="2">---snip-----</font>

<br><font face="Arial" size="2">RMCFG[nwvisus] TYPE=PBS</font>
</p>

<p><font face="Arial" size="2"># Allocation Manager Definition</font>
</p>

<p><font face="Arial" size="2">AMCFG[bank]&nbsp; TYPE=GOLD HOST=dbserver PORT=7112 SOCKETPROTOCOL=HTTP WIREPROTOCOL=XML CHARGEPOLICY=DEBITALLWC JOBFAILUREACTION=NON TIMEOUT=15</font></p>

<p><font face="Arial" size="2">---snip---</font>
</p>
<br>

<p><font face="Arial" size="2">And maui-private-cfg</font>
</p>

<p><font face="Arial" size="2">CLIENTCFG[AM:bank] CSKEY=my_super_secret_key CSALGO=HMAC</font>
</p>

<p><font face="Arial" size="2">Is there something interesting I should be looking for in either my Torque or Maui log files? </font>
</p>

<p><font face="Arial" size="2">Thanks</font>
</p>

<p><font face="Arial" size="2">Tim Carlson</font>

<br><font face="Arial" size="2">Voice: (509) 376 3423</font>

<br><font face="Arial" size="2">Email: <a href="mailto:Tim.Carlson@pnl.gov" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">Tim.Carlson@pnl.gov</a></font>

<br><font face="Arial" size="2">Pacific Northwest National Laboratory</font>

<br><font face="Arial" size="2">HPCaNS: High Performance Computing and Networking Services</font>
</p>

</div>

<br>_______________________________________________<br>mauiusers mailing list<br><a onclick="return top.js.OpenExtLink(window,event,this)" href="mailto:mauiusers@supercluster.org">mauiusers@supercluster.org</a><br><a onclick="return top.js.OpenExtLink(window,event,this)" href="http://www.supercluster.org/mailman/listinfo/mauiusers" target="_blank">
http://www.supercluster.org/mailman/listinfo/mauiusers</a><br><br><br></blockquote></div><br><br clear="all"><br>-- <br>Kevin Van Workum, Ph.D.<br>Vice President<br>Senior System Administrator<br><a href="http://www.clusterondemand.com">
www.clusterondemand.com</a><br>ONLINE COMPUTER CLUSTERS