<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii">
<META NAME="Generator" CONTENT="MS Exchange Server version 6.5.7651.59">
<TITLE>Problems with maui/gold/torque integration on 64 bit IRIX</TITLE>
</HEAD>
<BODY>
<!-- Converted from text/rtf format -->

<P><FONT SIZE=2 FACE="Arial">Here is my setup.</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">I would like to integrate Maui/Gold/Torque on an IRIX64 running IRIX 6.5.30. I've got everything compiled and running with the IRIX compilers and I can submit a job without a </FONT></P>

<P><FONT SIZE=2 FACE="Arial">#PBS -A myaccount</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">line and thins runs fine. However when I add in a #PBS -A line, my jobs exits without running&nbsp; and I get the following in my torque output file.</FONT></P>

<P><FONT SIZE=2 FACE="Arial">mom_close_poll: entered</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">And I get an email message of</FONT>
</P>

<P><FONT SIZE=2 FACE="Courier New">PBS Job Id: 4.nwvisus</FONT>

<BR><FONT SIZE=2 FACE="Courier New">Job Name:&nbsp;&nbsp; test</FONT>

<BR><FONT SIZE=2 FACE="Courier New">Aborted by PBS Server</FONT>

<BR><FONT SIZE=2 FACE="Courier New">Job cannot be executed</FONT>

<BR><FONT SIZE=2 FACE="Courier New">See job standard error file</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">The maui logs seem to indicate that gold was queried and in fact a charge was made after the job has run.</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">INFO:&nbsp;&nbsp;&nbsp;&nbsp; response received from server</FONT>

<BR><FONT SIZE=2 FACE="Arial">INFO:&nbsp;&nbsp;&nbsp;&nbsp; response received: '&lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8&quot;?&gt;</FONT>

<BR><FONT SIZE=2 FACE="Arial">&lt;Envelope&gt;&lt;Body&gt;&lt;Response actor=&quot;root&quot;&gt;&lt;Status&gt;&lt;Value&gt;Success&lt;/Value&gt;&lt;Code&gt;000&lt;/Code&gt;&lt;Message&gt;Successfully charged job 4 for 62 credits 1 reservations were removed&lt;/Message&gt;&lt;/Status&gt;&lt;Count&gt;62&lt;/Count&gt;&lt;Data&gt;&lt;Charge&gt;&lt;Amount&gt;62&lt;/Amount&gt;&lt;Job&gt;174840&lt;/Job&gt;&lt;/Charge&gt;&lt;/Data&gt;&lt;/Response&gt;&lt;/Body&gt;&lt;/Envelope&gt;</FONT></P>

<P><FONT SIZE=2 FACE="Arial">'</FONT>

<BR><FONT SIZE=2 FACE="Arial">MSUDisconnect(S)</FONT>

<BR><FONT SIZE=2 FACE="Arial">INFO:&nbsp;&nbsp;&nbsp;&nbsp; command response '&lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8&quot;?&gt;</FONT>

<BR><FONT SIZE=2 FACE="Arial">&lt;Envelope&gt;&lt;Body&gt;&lt;Response actor=&quot;root&quot;&gt;&lt;Status&gt;&lt;Value&gt;Success&lt;/Value&gt;&lt;Code&gt;000&lt;/Code&gt;&lt;Message&gt;Successfully charged job 4 for 62 credits</FONT></P>

<P><FONT SIZE=2 FACE="Arial">1 reservations were removed&lt;/Message&gt;&lt;/Status&gt;&lt;Count&gt;62&lt;/Count&gt;&lt;Data&gt;&lt;Charge&gt;&lt;Amount&gt;62&lt;/Amount&gt;&lt;Job&gt;174840&lt;/Job&gt;&lt;/Charge&gt;&lt;/Data&gt;&lt;/Response&gt;&lt;/Body&gt;&lt;/Envelope&gt;</FONT></P>

<P><FONT SIZE=2 FACE="Arial">'</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">However, in the logs before that I see where there were problems contacting the resource manager. Not sure if this is normal or not</FONT></P>

<P><FONT SIZE=2 FACE="Arial">ERROR:&nbsp;&nbsp;&nbsp; cannot receive response from allocation-manager server 'dbserver':7112</FONT>

<BR><FONT SIZE=2 FACE="Arial">MSysRegEvent(FAILURE:&nbsp; cannot receive response from allocation-manager server dbserver:7112 (cmd: '&lt;XML&gt;')</FONT>

<BR><FONT SIZE=2 FACE="Arial">,0,0,1)</FONT>

<BR><FONT SIZE=2 FACE="Arial">MSysLaunchAction(ASList,1)</FONT>

<BR><FONT SIZE=2 FACE="Arial">INFO:&nbsp;&nbsp;&nbsp;&nbsp; command response 'NULL'</FONT>

<BR><FONT SIZE=2 FACE="Arial">ALERT:&nbsp;&nbsp;&nbsp; no job data available</FONT>

<BR><FONT SIZE=2 FACE="Arial">ALERT:&nbsp;&nbsp;&nbsp; cannot extract status</FONT>

<BR><FONT SIZE=2 FACE="Arial">ALERT:&nbsp;&nbsp;&nbsp; cannot reserve allocation for job</FONT>

<BR><FONT SIZE=2 FACE="Arial">WARNING:&nbsp; cannot reserve allocation for job '4', reason: BankFailure</FONT>

<BR><FONT SIZE=2 FACE="Arial">MRMJobStart(4,Msg,SC)</FONT>

<BR><FONT SIZE=2 FACE="Arial">MPBSJobStart4,nwvisus,Msg,SC)</FONT>

<BR><FONT SIZE=2 FACE="Arial">MPBSJobModify4,Resource_List,Resource,nwvisus:ppn=2)</FONT>

<BR><FONT SIZE=2 FACE="Arial">MPBSJobModify(4,Resource_List,Resource,1:ppn=2)</FONT>
</P>
<BR>
<BR>

<P><FONT SIZE=2 FACE="Arial">I built both Torque-2.1.6 and Maui-2.6.18 in 64 bit mode and fixed the configure problem in Torque so that the linker tried to link 64 bit and add the -D__M64 to the OSCCFLAGS of Maui.&nbsp; I've also tried Torque-2.0.0pXX and snapshot version of Maui. All of this with gold-2.0.0.7</FONT></P>

<P><FONT SIZE=2 FACE="Arial">I can query my gold database with basic gold commands from this machine and I'm fairly sure I have&nbsp; configured my maui.cfg maui-private.cfg file correctly </FONT></P>

<P><FONT SIZE=2 FACE="Arial">maui.cfg</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">---snip-----</FONT>

<BR><FONT SIZE=2 FACE="Arial">RMCFG[nwvisus] TYPE=PBS</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial"># Allocation Manager Definition</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">AMCFG[bank]&nbsp; TYPE=GOLD HOST=dbserver PORT=7112 SOCKETPROTOCOL=HTTP WIREPROTOCOL=XML CHARGEPOLICY=DEBITALLWC JOBFAILUREACTION=NON TIMEOUT=15</FONT></P>

<P><FONT SIZE=2 FACE="Arial">---snip---</FONT>
</P>
<BR>

<P><FONT SIZE=2 FACE="Arial">And maui-private-cfg</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">CLIENTCFG[AM:bank] CSKEY=my_super_secret_key CSALGO=HMAC</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">Is there something interesting I should be looking for in either my Torque or Maui log files? </FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">Thanks</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">Tim Carlson</FONT>

<BR><FONT SIZE=2 FACE="Arial">Voice: (509) 376 3423</FONT>

<BR><FONT SIZE=2 FACE="Arial">Email: Tim.Carlson@pnl.gov</FONT>

<BR><FONT SIZE=2 FACE="Arial">Pacific Northwest National Laboratory</FONT>

<BR><FONT SIZE=2 FACE="Arial">HPCaNS: High Performance Computing and Networking Services</FONT>
</P>

</BODY>
</HTML>