<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
<pre wrap="">Marc, Qadir, All

Please correct me if I am wrong, but the nodes file is for job execution hosts only.  We encountered this problem, and were able to make it work by making sure that the internal interface (pbs_server_name )  that talks to the execution hosts is first in the lists of aliases for that IP in the /etc/hosts file.  As well, we have all nodes in /etc/hosts.equiv.

here is my line in /etc/hosts for the pbs_server's private network IP:

172.30.80.252   sadmin2 pbs_server 

[root@sadmin2 root]# cat /var/spool/pbs/server_name 
sadmin2


Jerry


Message: 7
Date: Tue, 22 Nov 2005 11:27:00 -0700
From: Marc Langlois <a class="moz-txt-link-rfc2396E"
 href="mailto:marc@keyseismic.com">&lt;marc@keyseismic.com&gt;</a>
Subject: Re: [Mauiusers] Premature end of message - ?
To: Qadir Timerghazin <a class="moz-txt-link-rfc2396E"
 href="mailto:qadir.timerghazin@gmail.com">&lt;qadir.timerghazin@gmail.com&gt;</a>
Cc: <a class="moz-txt-link-abbreviated"
 href="mailto:mauiusers@supercluster.org">mauiusers@supercluster.org</a>
Message-ID: &lt;1132684020.325.19.camel@dev01&gt;
Content-Type: text/plain

Qadir,

I had a similar problem with 2 network interfaces on the Torque server
node. I added $clienthost entries for hostnames of both interfaces to
./mom_priv/config, but it didn't help. 

After increasing the debug levels in the MOMs and the server, it
appeared (IIRC) to be caused by the trusted host list being set by the
Torque server (and not by MOM). Jobs started running properly after I
added the hostnames for both interfaces to the ./server_priv/nodes file.

Hope this helps,
Marc.
 
On Mon, 2005-11-21 at 12:49, Qadir Timerghazin wrote:
</pre>
<blockquote type="cite">
  <pre wrap=""><span class="moz-txt-citetags">&gt; </span>Hello all,
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>I am trying to setup Torque/Maui at a small Linux cluster, with the
<span class="moz-txt-citetags">&gt; </span>nodes inside the private network and the headnode with two network
<span class="moz-txt-citetags">&gt; </span>interfaces. While the test installation using one of the cluster nodes as
<span class="moz-txt-citetags">&gt; </span>a queue master and two other nodes as execution hosts worked perfectly,
<span class="moz-txt-citetags">&gt; </span>I can not make it work at the headnode: all the jobs get stuck and
<span class="moz-txt-citetags">&gt; </span>checkjob gives the following:
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>--------------------------------
<span class="moz-txt-citetags">&gt; </span>Holds:    Defer
<span class="moz-txt-citetags">&gt; </span>Messages:  cannot start job - RM failure, rc: 15031, msg: 'Premature end
<span class="moz-txt-citetags">&gt; </span>of message'
<span class="moz-txt-citetags">&gt; </span>PE:  1.00  StartPriority:  1
<span class="moz-txt-citetags">&gt; </span>cannot select job 0 for partition DEFAULT (job hold active)
<span class="moz-txt-citetags">&gt; </span>--------------------------------
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>I tried changing the server hostname in Torque and Maui configuration
<span class="moz-txt-citetags">&gt; </span>files from internal to external and back without much success. Do you
<span class="moz-txt-citetags">&gt; </span>think the 'Premature end of message' error has to do with the hostname
<span class="moz-txt-citetags">&gt; </span>confusion or I should look somewhere else? 
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>Thank you.
<span class="moz-txt-citetags">&gt; </span>
<span class="moz-txt-citetags">&gt; </span>Qadir
  </pre>
</blockquote>
<pre wrap=""><!----><div class="moz-txt-sig">-- 
Marc Langlois
Key Seismic Solutions Ltd., Calgary, AB, Canada.
marc at keyseismic.com



</div></pre>
</body>
</html>